summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2016-01-04 13:15:45 +0800
committerquininer2016-01-04 13:16:39 +0800
commit89bdf0e17e9519d21003c2d1814816238ce8e1c9 (patch)
tree73be04db8beec3966263e9656238e3e33bd31fde
downloadaur-89bdf0e17e9519d21003c2d1814816238ce8e1c9.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..186f5eeadc38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Jan 4 05:15:21 UTC 2016
+pkgbase = ydcv-rs-git
+ pkgdesc = A Rust version of ydcv.
+ pkgver = 0.3.1.48
+ pkgrel = 1
+ url = https://github.com/farseerfc/ydcv-rs
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = GPLv2
+ makedepends = git
+ makedepends = cargo
+ makedepends = python-pytoml
+ provides = ydcv
+ conflicts = ydcv
+ source = git://github.com/farseerfc/ydcv-rs.git
+ sha256sums = SKIP
+
+pkgname = ydcv-rs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87371f12e9bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=ydcv-rs-git
+_gitname="ydcv-rs"
+pkgdesc="A Rust version of ydcv."
+pkgver=0.3.1.48
+pkgrel=1
+arch=('i686' 'x86_64')
+conflicts=("ydcv")
+provides=("ydcv")
+url="https://github.com/farseerfc/ydcv-rs"
+license=('MIT' 'GPLv2')
+depends=('curl')
+makedepends=('git' 'cargo' 'python-pytoml')
+source=('git://github.com/farseerfc/ydcv-rs.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo "$(python -c "print(__import__('pytoml').loads(open('Cargo.toml').read())['package']['version'])").$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd $_gitname
+ # cargo build --no-default-features --features "hyper notify-rust" --release
+ cargo build --release
+}
+
+package() {
+ cd $_gitname
+ install -D -m755 "${srcdir}/${_gitname}/target/release/ydcv-rs" "${pkgdir}/usr/bin/ydcv"
+}