summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhanhan2020-09-05 14:45:21 +0800
committerhanhan2020-09-05 14:45:21 +0800
commit1cb80dd8a9a799896ca18072f3315115959c5143 (patch)
tree684b2ba56447e0d945e6c75bb033c75c05cab60d
downloadaur-1cb80dd8a9a799896ca18072f3315115959c5143.tar.gz
0.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18257c8c3bd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ydict
+ pkgdesc = dictionary/translation tool developed in Rust+Qt
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/DreamSaddle/youdao-dict
+ arch = x86_64
+ license = GPL3
+ source = https://github.com/DreamSaddle/youdao-dict/releases/download/0.3.0/YDict-0.3.0.tar.gz
+ md5sums = SKIP
+
+pkgname = ydict
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52d00e69bfb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Your Name <1289747698@qq.com>
+
+pkgname=ydict
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="dictionary/translation tool developed in Rust+Qt"
+arch=('x86_64')
+url="https://github.com/DreamSaddle/youdao-dict"
+license=('GPL3')
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/DreamSaddle/youdao-dict/releases/download/$pkgver/YDict-$pkgver.tar.gz")
+noextract=()
+md5sums=('SKIP')
+
+prepare() {
+ echo ""
+}
+
+build() {
+ echo "此软件通过打包好的二进制文件安装, 无需编译."
+}
+
+package() {
+ cd "YDict-$pkgver/scripts"
+ chmod +x install.sh
+ ./install.sh
+}