summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2021-03-22 00:05:37 +0100
committerEric Engestrom2021-03-22 00:13:02 +0100
commit6e2ed97885dd4b13f6141c0035cc92ccffd1b4f4 (patch)
tree722252c5e744a2ebe4b3e638170ce9267e644cd9
parent7a554189a71247ae4de37f00da40ff916ca14136 (diff)
downloadaur-6e2ed97885dd4b13f6141c0035cc92ccffd1b4f4.tar.gz
add post-install/upgrade note about being in the `input` group
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD1
-rw-r--r--ydotool.install8
4 files changed, 11 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e89004dfcde4..462003bec8da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = ydotool
pkgver = 0.2.0
pkgrel = 1
url = https://github.com/ReimuNotMoe/ydotool
+ install = ydotool.install
arch = x86_64
license = AGPL3
makedepends = cmake
diff --git a/.gitignore b/.gitignore
index 6af0bc0a224a..c774706524ce 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*
!80-uinput.rules
+!ydotool.install
!PKGBUILD
!.SRCINFO
!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 15cb1af4f113..facfdc428dd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,7 @@ source=("$url/archive/v$pkgver.tar.gz"
sha256sums=('2311b003d2ff383f3348f17101f0df74f56616d530d66d0a014a52ba85a5dcf1'
'f462b5f62306a5431e5aa39d1a8ba670300f7304a15cc720af5ded65193eaeda'
'e092f5e7e474aec6c980c458046d0ff11b18750b53de2bf0a0aba1ca26e6d58e')
+install=ydotool.install
prepare() {
cd "$pkgname-$pkgver"
diff --git a/ydotool.install b/ydotool.install
new file mode 100644
index 000000000000..065f9b4e1ea8
--- /dev/null
+++ b/ydotool.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo 'Make sure your user is in the `input` group by running the following command:'
+ echo ' $ usermod -aG input $USER'
+}
+
+post_upgrade() {
+ post_install
+}