summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvedui2022-03-11 15:37:18 +0100
committerArvedui2022-03-11 15:37:18 +0100
commitacb71a5672aa4077b5c55cc1079dd086453deaad (patch)
tree3f0f058a9cffe88ef537a21bb9a7ddc6d81c38c9
parent3d582f978636ffcd1e98be5a6a0f476a41863f41 (diff)
downloadaur-acb71a5672aa4077b5c55cc1079dd086453deaad.tar.gz
ydotool: upstream release 1.0.1-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26e203344657..27d3f08a31ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ydotool
pkgdesc = Generic command-line automation tool (no X!)
- pkgver = 0.2.0
- pkgrel = 2
+ pkgver = 1.0.1
+ pkgrel = 1
url = https://github.com/ReimuNotMoe/ydotool
install = ydotool.install
arch = x86_64
@@ -12,12 +12,9 @@ pkgbase = ydotool
makedepends = scdoc
depends = libevdevplus
depends = libuinputplus
- source = https://github.com/ReimuNotMoe/ydotool/archive/v0.2.0.tar.gz
- source = https://github.com/ReimuNotMoe/ydotool/pull/96.patch
+ source = ydotool-1.0.1.tar.gz::https://github.com/ReimuNotMoe/ydotool/archive/v1.0.1.tar.gz
source = 80-uinput.rules
- sha256sums = 2311b003d2ff383f3348f17101f0df74f56616d530d66d0a014a52ba85a5dcf1
- sha256sums = f462b5f62306a5431e5aa39d1a8ba670300f7304a15cc720af5ded65193eaeda
+ sha256sums = 02311cdc608f205711b06a95e5fd71093b2294f4920efc526f5e98a2ddab42b8
sha256sums = e092f5e7e474aec6c980c458046d0ff11b18750b53de2bf0a0aba1ca26e6d58e
pkgname = ydotool
-
diff --git a/PKGBUILD b/PKGBUILD
index b58ce5a4c212..c5dbc208bbcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=ydotool
-pkgver=0.2.0
-pkgrel=2
+pkgver=1.0.1
+pkgrel=1
pkgdesc="Generic command-line automation tool (no X!)"
arch=('x86_64' 'aarch64')
depends=('libevdevplus' 'libuinputplus')
makedepends=('cmake' 'ninja' 'scdoc')
url="https://github.com/ReimuNotMoe/ydotool"
license=('AGPL3')
-source=("$url/archive/v$pkgver.tar.gz"
- "$url/pull/96.patch"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"80-uinput.rules")
-sha256sums=('2311b003d2ff383f3348f17101f0df74f56616d530d66d0a014a52ba85a5dcf1'
- 'f462b5f62306a5431e5aa39d1a8ba670300f7304a15cc720af5ded65193eaeda'
+sha256sums=('02311cdc608f205711b06a95e5fd71093b2294f4920efc526f5e98a2ddab42b8'
'e092f5e7e474aec6c980c458046d0ff11b18750b53de2bf0a0aba1ca26e6d58e')
install=ydotool.install
prepare() {
cd "$pkgname-$pkgver"
- patch -sp1 -i ../96.patch
}
build() {