summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2023-08-20 14:39:25 -0500
committerkyechou2023-08-20 14:39:25 -0500
commit63fe855fa417e11e6c3045fe9f825ab12e054656 (patch)
tree5589c8433bc779df4797666280f8b026f725bae7
parent9a195e7b8b0ae9f73e588da58eaee062616fb4a9 (diff)
downloadaur-ydotool-git.tar.gz
Minor update
-rw-r--r--.SRCINFO8
-rw-r--r--80-uinput.rules4
-rw-r--r--PKGBUILD19
-rw-r--r--ydotool.install2
4 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 627696217e7a..c6feeb795606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ydotool-git
pkgdesc = Generic command-line automation tool (no X!)
- pkgver = 0.0.1.r2.g1d5d227
+ pkgver = 1.0.4.r0.g57ba7d0
pkgrel = 1
epoch = 1
url = https://github.com/ReimuNotMoe/ydotool
@@ -11,11 +11,13 @@ pkgbase = ydotool-git
makedepends = cmake
makedepends = ninja
makedepends = scdoc
+ makedepends = systemd
+ depends = glibc
provides = ydotool
conflicts = ydotool
- source = ydotool-git::git+https://github.com/ReimuNotMoe/ydotool.git
+ source = ydotool-git::git+https://github.com/ReimuNotMoe/ydotool
source = 80-uinput.rules
sha256sums = SKIP
- sha256sums = e839f6a07c79fedea58c3ef3d3ce2370a870ffcc503fc2a64ded9f11d513ef24
+ sha256sums = 8613c8c45b9e467e5f16cb438d740598c19625d2412f52e306cbe91ccb08dbd9
pkgname = ydotool-git
diff --git a/80-uinput.rules b/80-uinput.rules
index 11cd089cbdf2..cb9094ebfafd 100644
--- a/80-uinput.rules
+++ b/80-uinput.rules
@@ -1,2 +1,4 @@
-# https://github.com/ReimuNotMoe/ydotool/issues/25#issuecomment-535842993
+## ydotoold fix
+## https://github.com/ReimuNotMoe/ydotool/issues/25#issuecomment-535842993
+## This allows users in group input to use ydotool without root permissions.
KERNEL=="uinput", GROUP="input", MODE="0660", OPTIONS+="static_node=uinput"
diff --git a/PKGBUILD b/PKGBUILD
index 925005722589..6c27baa46313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Davide Depau <davide@depau.eu>
+# Contributor: Davide Depau <davide@depau.eu>
+# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=ydotool-git
-pkgver=0.0.1.r2.g1d5d227
+pkgver=1.0.4.r0.g57ba7d0
pkgrel=1
epoch=1
pkgdesc="Generic command-line automation tool (no X!)"
-depends=()
-makedepends=('git' 'cmake' 'ninja' 'scdoc')
-arch=(any)
+depends=('glibc')
+makedepends=('git' 'cmake' 'ninja' 'scdoc' 'systemd')
+arch=('any')
url="https://github.com/ReimuNotMoe/ydotool"
license=('AGPL3')
-provides=(ydotool)
-conflicts=(ydotool)
+provides=('ydotool')
+conflicts=('ydotool')
install=ydotool.install
-source=("$pkgname::git+https://github.com/ReimuNotMoe/ydotool.git"
+source=("$pkgname::git+$url"
'80-uinput.rules')
sha256sums=('SKIP'
- 'e839f6a07c79fedea58c3ef3d3ce2370a870ffcc503fc2a64ded9f11d513ef24')
+ '8613c8c45b9e467e5f16cb438d740598c19625d2412f52e306cbe91ccb08dbd9')
pkgver() {
cd "$srcdir/$pkgname"
diff --git a/ydotool.install b/ydotool.install
index 3108648b7ccb..0ab503dc0dac 100644
--- a/ydotool.install
+++ b/ydotool.install
@@ -1,6 +1,6 @@
post_install() {
echo 'Make sure your user is in the `input` group by running the following command:'
- echo ' $ gpasswd -a $USER input'
+ echo ' # gpasswd -a $USER input'
}
post_upgrade() {