summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2020-03-07 08:39:56 +0100
committerDavide Depau2020-03-07 08:39:56 +0100
commit8c9b090b835089222cb72872a822dfb7d8b1c2b4 (patch)
tree943307584dd8df3f31460cc2c0a36bf80bfe81f4
parent079f6438d08656638a66a48264e976d830ce0f34 (diff)
downloadaur-8c9b090b835089222cb72872a822dfb7d8b1c2b4.tar.gz
Work around upstream packaging bug
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1bef7221210..fcc1b988ac21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ydotool-git
pkgdesc = Generic command-line automation tool (no X!), works on Wayland
pkgver = v0.1.8.r29.g7764122
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ReimuNotMoe/ydotool
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index cfc6d54082e6..08324541cdaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=ydotool
pkgname=$_pkgname-git
pkgver=v0.1.8.r29.g7764122
-pkgrel=2
+pkgrel=3
pkgdesc="Generic command-line automation tool (no X!), works on Wayland"
arch=('i686' 'x86_64')
depends=('libevdevplus' 'libuinputplus' 'boost-libs')
@@ -27,7 +27,7 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_BUILD_TYPE=Release \
-DSTATIC_BUILD=0
make
@@ -37,4 +37,9 @@ package() {
cd "$srcdir/${_pkgname}"
make DESTDIR="$pkgdir" install -C build/
install -Dm644 Daemon/ydotool.service "$pkgdir/usr/lib/systemd/ydotool.service"
+
+ # Workaround upstream bug
+ if [ -f "$pkgdir/usr/bin/libydotool.so" ]; then
+ mv "$pkgdir/usr/"{bin,lib}"/libydotool.so"
+ fi
}