summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbobi2020-01-18 11:26:49 +0100
committerMichael Lass2020-01-18 22:01:02 +0100
commit2b8a0ff226e2c473372a5f9c93656957ee681a99 (patch)
tree7f97344dbce2e315fa1fa7632418f43a318e348e
parent28d0099fbb6bf0740e93d73f77889e437484480a (diff)
downloadaur-2b8a0ff226e2c473372a5f9c93656957ee681a99.tar.gz
yEd scalable icon + graphml mime type
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--graphml+xml-mime.xml8
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eb5b6fe2c71..be33ac85085f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yed
pkgdesc = Very powerful graph editor written in java
pkgver = 3.19.1.1
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://www.yworks.com/en/products_yed_about.html
install = yed.install
@@ -11,9 +11,11 @@ pkgbase = yed
source = https://www.yworks.com/resources/yed/demo/yEd-3.19.1.1.zip
source = yed.desktop
source = yed
+ source = graphml+xml-mime.xml
sha256sums = 3639da2650976bffcd43a8ea830727bae86478e95ceb4d68ad6363a42a8f1efb
sha256sums = 245182a52896bdff3f2c995a066623619d600665630e789910c92d36725a0aca
sha256sums = 731b54c6e731704efe9847d78e2df474d59042452ace29d2786d76891295249e
+ sha256sums = e751b69ed8a25faf46d4e4016ed8f1774abc88679067934a6081348e3d6fc332
pkgname = yed
diff --git a/PKGBUILD b/PKGBUILD
index a1d003c2f9c1..9ee4cf9f1c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=yed
pkgver=3.19.1.1
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Very powerful graph editor written in java'
arch=('any')
@@ -20,10 +20,12 @@ license=('custom')
depends=('java-runtime')
source=("https://www.yworks.com/resources/yed/demo/yEd-${pkgver}.zip"
'yed.desktop'
- 'yed')
+ 'yed'
+ 'graphml+xml-mime.xml')
sha256sums=('3639da2650976bffcd43a8ea830727bae86478e95ceb4d68ad6363a42a8f1efb'
'245182a52896bdff3f2c995a066623619d600665630e789910c92d36725a0aca'
- '731b54c6e731704efe9847d78e2df474d59042452ace29d2786d76891295249e')
+ '731b54c6e731704efe9847d78e2df474d59042452ace29d2786d76891295249e'
+ 'e751b69ed8a25faf46d4e4016ed8f1774abc88679067934a6081348e3d6fc332')
install=yed.install
@@ -36,8 +38,13 @@ package() {
# Install license
install -Dm644 ${srcdir}/yed-${pkgver}/license.html ${pkgdir}/usr/share/licenses/yed/license.html
- # Install icon
- install -Dm644 ${srcdir}/yed-${pkgver}/icons/yed32.png ${pkgdir}/usr/share/pixmaps/yed.png
+ # Install icons
+ for n in $(ls ${srcdir}/yed-${pkgver}/icons/yed*.png | xargs -n1 basename | sed s/[^0-9]//g); do
+ install -Dm644 ${srcdir}/yed-${pkgver}/icons/yed${n}.png ${pkgdir}/usr/share/icons/hicolor/${n}x${n}/apps/yed.png
+ done
+
+ # Install mime definition
+ install -Dm644 ${srcdir}/graphml+xml-mime.xml ${pkgdir}/usr/share/mime/packages/graphml+xml-mime.xml
# Install .desktop file
install -Dm644 ${srcdir}/yed.desktop ${pkgdir}/usr/share/applications/yed.desktop
diff --git a/graphml+xml-mime.xml b/graphml+xml-mime.xml
new file mode 100644
index 000000000000..09ee9735f9bd
--- /dev/null
+++ b/graphml+xml-mime.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-graphml+xml">
+ <comment>yEd graphml file (xml format)</comment>
+ <glob pattern="*.graphml"/>
+ <generic-icon name="x-application-graphml+xml"/>
+ </mime-type>
+</mime-info>