summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2016-07-28 15:45:33 +0200
committerMichael Lass2016-07-28 15:45:33 +0200
commit568592fad2f6b566ef69d329740dee791cf76b21 (patch)
treec8fbcae97705a460d30305da32d95101b23b59d8
parentc6db8f040a062bf98645824a3ad318a4d0e2a3c3 (diff)
downloadaur-568592fad2f6b566ef69d329740dee791cf76b21.tar.gz
yed now depends on Java 8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--yed5
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef9ea81a0466..13c6d50c519d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Tue Jul 26 17:52:43 UTC 2016
+# Thu Jul 28 13:45:24 UTC 2016
pkgbase = yed
pkgdesc = Very powerful graph editor written in java
pkgver = 3.16
- pkgrel = 1
+ pkgrel = 2
url = http://www.yworks.com/en/products_yed_about.html
install = yed.install
arch = any
license = custom
- depends = java-runtime
+ depends = java-runtime>=8
source = http://www.yworks.com/products/yed/demo/yEd-3.16.zip
source = yed.desktop
source = yed
sha256sums = 1dc24758535ca033eb5f078524193c9ffcc98635d2832fd403ca9aec01e24bea
sha256sums = 342dba6defac88d035253b22e6377d9570858f59367cd486dba4a4dba1621f91
- sha256sums = fee9aff48421fb51f623a371a9aa12c70f388a05f3015b6a3b7c9798312e8e8a
+ sha256sums = 659784d530d9a3f6a9489d6493b29e947bf534a8da9750b19a907ead1fe2e8ac
pkgname = yed
diff --git a/PKGBUILD b/PKGBUILD
index b184587e314b..b8d5a0b82929 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,18 @@
pkgname=yed
pkgver=3.16
-pkgrel=1
+pkgrel=2
pkgdesc='Very powerful graph editor written in java'
arch=('any')
url='http://www.yworks.com/en/products_yed_about.html'
license=('custom')
-depends=('java-runtime')
+depends=('java-runtime>=8')
source=("http://www.yworks.com/products/yed/demo/yEd-${pkgver}.zip"
'yed.desktop'
'yed')
sha256sums=('1dc24758535ca033eb5f078524193c9ffcc98635d2832fd403ca9aec01e24bea'
'342dba6defac88d035253b22e6377d9570858f59367cd486dba4a4dba1621f91'
- 'fee9aff48421fb51f623a371a9aa12c70f388a05f3015b6a3b7c9798312e8e8a')
+ '659784d530d9a3f6a9489d6493b29e947bf534a8da9750b19a907ead1fe2e8ac')
install=${pkgname}.install
diff --git a/yed b/yed
index e763834df9d7..8e17176d6d42 100644
--- a/yed
+++ b/yed
@@ -1,4 +1,5 @@
#!/bin/sh
-java -jar /usr/share/yed/yed.jar "$@"
-
+# Force usage of latest java version
+JVM_PATH=$(find /usr/lib/jvm/* -maxdepth 0 -type d | sort | tail -n1)
+exec $JVM_PATH/jre/bin/java -jar /usr/share/yed/yed.jar "$@"