summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2017-02-03 15:17:35 +0100
committerMichael Lass2017-02-03 15:17:35 +0100
commit9b3893bf168e6b647c0fd4b112e0a46a1d0f7095 (patch)
treecddfe70bce6d6ff72c13b562c7c67c4f1083ccc1
parentf58d711db7340a4ac7dff19c80ca601fb5b198c8 (diff)
downloadaur-9b3893bf168e6b647c0fd4b112e0a46a1d0f7095.tar.gz
Improve start script
If a suitable java version is selected via archlinux-java we should use it. Otherwise use the latest version available as we did before.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--yed10
3 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fe0fb279d9f..47441f323b23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 12 17:15:36 UTC 2016
+# Fri Feb 3 14:17:14 UTC 2017
pkgbase = yed
pkgdesc = Very powerful graph editor written in java
pkgver = 3.16.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.yworks.com/en/products_yed_about.html
install = yed.install
arch = any
@@ -14,7 +14,7 @@ pkgbase = yed
source = yed
sha256sums = 47ac746ad30eb6375b8f45e9382efd0db0b6e3b1eb8f4760625963175b753805
sha256sums = 342dba6defac88d035253b22e6377d9570858f59367cd486dba4a4dba1621f91
- sha256sums = 659784d530d9a3f6a9489d6493b29e947bf534a8da9750b19a907ead1fe2e8ac
+ sha256sums = cea06705c5b9981874bf5b84924bdf3b1d0cf9445e91c32f8d6bb117011f8e02
pkgname = yed
diff --git a/PKGBUILD b/PKGBUILD
index 1db1ab56df1e..65d5aa2553cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=yed
pkgver=3.16.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Very powerful graph editor written in java'
arch=('any')
url='http://www.yworks.com/en/products_yed_about.html'
@@ -21,7 +21,7 @@ source=("http://www.yworks.com/resources/yed/demo/yEd-${pkgver}.zip"
'yed')
sha256sums=('47ac746ad30eb6375b8f45e9382efd0db0b6e3b1eb8f4760625963175b753805'
'342dba6defac88d035253b22e6377d9570858f59367cd486dba4a4dba1621f91'
- '659784d530d9a3f6a9489d6493b29e947bf534a8da9750b19a907ead1fe2e8ac')
+ 'cea06705c5b9981874bf5b84924bdf3b1d0cf9445e91c32f8d6bb117011f8e02')
install=${pkgname}.install
diff --git a/yed b/yed
index 8e17176d6d42..3c28bd91d20e 100644
--- a/yed
+++ b/yed
@@ -1,5 +1,9 @@
#!/bin/sh
-# Force usage of latest java version
-JVM_PATH=$(find /usr/lib/jvm/* -maxdepth 0 -type d | sort | tail -n1)
-exec $JVM_PATH/jre/bin/java -jar /usr/share/yed/yed.jar "$@"
+if [[ "$(archlinux-java get)" == java-8-* ]]; then
+ exec /usr/bin/java -jar /usr/share/yed/yed.jar "$@"
+else
+ # Force usage of latest java version
+ JVM_PATH=$(find /usr/lib/jvm/* -maxdepth 0 -type d | sort | tail -n1)
+ exec $JVM_PATH/jre/bin/java -jar /usr/share/yed/yed.jar "$@"
+fi