summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2015-06-08 20:53:17 +0200
committerMichael Lass2015-06-08 20:53:17 +0200
commitee49b0e20e0cccae726c06dbb7865d310fc9dd91 (patch)
treee287abeceb88a44339a61e4d68ad1600b48ee68b
downloadaur-ee49b0e20e0cccae726c06dbb7865d310fc9dd91.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
-rw-r--r--yed4
-rw-r--r--yed.desktop8
-rw-r--r--yed.install13
5 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d7d54445f0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = yed
+ pkgdesc = Very powerful graph editor written in java
+ pkgver = 3.14.2
+ pkgrel = 1
+ url = http://www.yworks.com/en/products_yed_about.html
+ install = yed.install
+ arch = any
+ license = custom
+ depends = java-runtime
+ source = http://www.yworks.com/products/yed/demo/yEd-3.14.2.zip
+ source = yed.desktop
+ source = yed
+ sha256sums = d08e43a17dd078fda66419715fc45d7fe62fd361bf14a705b1b1037c2eb34ec4
+ sha256sums = 342dba6defac88d035253b22e6377d9570858f59367cd486dba4a4dba1621f91
+ sha256sums = fee9aff48421fb51f623a371a9aa12c70f388a05f3015b6a3b7c9798312e8e8a
+
+pkgname = yed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5348c5aa3cde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Michael Lass <bevan@bi-co.net>
+# Contributor: Sebastian Wolf < sebastian at melonkru dot de >
+# Contributor: gost < gostrc at gmail dot com >
+# Contributor: Mikolaj Pastuszko <deluminathor@gmail.com>
+# Contributor: Stefan Seemayer < mail at semicolonsoftware dot de >
+# Contributor: Gordin < 9ordin @t gmail dot com >
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
+
+pkgname=yed
+pkgver=3.14.2
+pkgrel=1
+pkgdesc='Very powerful graph editor written in java'
+arch=('any')
+url='http://www.yworks.com/en/products_yed_about.html'
+license=('custom')
+depends=('java-runtime')
+source=("http://www.yworks.com/products/yed/demo/yEd-${pkgver}.zip"
+ 'yed.desktop'
+ 'yed')
+sha256sums=('d08e43a17dd078fda66419715fc45d7fe62fd361bf14a705b1b1037c2eb34ec4'
+ '342dba6defac88d035253b22e6377d9570858f59367cd486dba4a4dba1621f91'
+ 'fee9aff48421fb51f623a371a9aa12c70f388a05f3015b6a3b7c9798312e8e8a')
+
+install=${pkgname}.install
+
+package() {
+ # Install jars
+ install -Dm644 ${srcdir}/yed-${pkgver}/yed.jar ${pkgdir}/usr/share/yed/yed.jar
+ install -dm755 ${pkgdir}/usr/share/yed/lib
+ install -m644 ${srcdir}/yed-${pkgver}/lib/* ${pkgdir}/usr/share/yed/lib/
+
+ # Install license
+ install -Dm644 ${srcdir}/yed-${pkgver}/license.html ${pkgdir}/usr/share/licenses/yed/license.html
+
+ # Install icon
+ install -Dm644 ${srcdir}/yed-${pkgver}/icons/yicon32.png ${pkgdir}/usr/share/pixmaps/yed.png
+
+ # Install .desktop file
+ install -Dm644 ${srcdir}/yed.desktop ${pkgdir}/usr/share/applications/yed.desktop
+
+ # Install run script
+ install -Dm755 ${srcdir}/yed ${pkgdir}/usr/bin/yed
+}
diff --git a/yed b/yed
new file mode 100644
index 000000000000..e763834df9d7
--- /dev/null
+++ b/yed
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+java -jar /usr/share/yed/yed.jar "$@"
+
diff --git a/yed.desktop b/yed.desktop
new file mode 100644
index 000000000000..6491a8b4dd38
--- /dev/null
+++ b/yed.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Icon=yed
+Exec=yed %f
+StartupNotify=true
+StartupWMClass=B-A-A-B
+Name=yEd Graph Editor
+Categories=Application;Graphics;VectorGraphics;Java;
diff --git a/yed.install b/yed.install
new file mode 100644
index 000000000000..cd0dfe2b7209
--- /dev/null
+++ b/yed.install
@@ -0,0 +1,13 @@
+post_upgrade() {
+ post_install $1
+}
+
+post_install() {
+ echo ">>> You have to read and accept the license agreement under"
+ echo ">>> /usr/share/licenses/yed/license.html before using yEd."
+}
+
+op=$1
+shift
+$op $*
+