summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharalampos Tsipizidis2017-10-28 21:52:06 +0300
committerCharalampos Tsipizidis2017-10-28 21:55:24 +0300
commitd0da42d0e811114fdc84ac1208013eda653cf97a (patch)
tree3786d5ea60f82d2132fe13977b78da29212d906c
downloadaur-d0da42d0e811114fdc84ac1208013eda653cf97a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0518782c9880
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yeecli
+ pkgdesc = Yeelight CLI tool
+ pkgver = r49.6e391b5
+ pkgrel = 1
+ url = https://gitlab.com/stavros/yeecli
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-yeelight
+ provides = yeecli
+ source = git+https://gitlab.com/stavros/yeecli.git
+ md5sums = SKIP
+
+pkgname = yeecli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc1e292fa920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: tsipizic
+
+pkgname="yeecli"
+pkgver=r49.6e391b5
+pkgrel=1
+pkgdesc="Yeelight CLI tool"
+arch=("i686" "x86_64")
+url="https://gitlab.com/stavros/yeecli"
+license=("BSD")
+depends=("python-yeelight")
+makedepends=("git" "python-setuptools")
+provides=("yeecli")
+source=("git+https://gitlab.com/stavros/yeecli.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+