summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClansty2021-04-28 22:55:20 +0800
committerClansty2021-04-28 22:55:20 +0800
commitdfbb99bb9fd476239b1786add6bbcead0c486e46 (patch)
tree1151b7dc0b5b6500c837a640a5ba40ade5a5bc63
parent9c4c1c424c5fd18b642ad9cc3faa222d0f01c2d4 (diff)
downloadaur-dfbb99bb9fd476239b1786add6bbcead0c486e46.tar.gz
a
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--yesplaymusic2
-rw-r--r--yesplaymusic.desktop2
4 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52094f843665..14747a7cded8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yesplaymusic-electron
pkgdesc = A third party music application for Netease Music. Using the system electron
pkgver = 0.3.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/qier222/YesPlayMusic
arch = any
license = MIT
@@ -19,10 +19,15 @@ pkgbase = yesplaymusic-electron
optdepends = snappy
optdepends = libnotify
optdepends = libappindicator-gtk3
+ provides = yesplaymusic
+ conflicts = yesplaymusic
+ replaces = yesplaymusic
source = YesPlayMusic-0.3.7.pacman::https://github.com/qier222/YesPlayMusic/releases/download/v0.3.7/YesPlayMusic-0.3.7.pacman
source = yesplaymusic.desktop
+ source = yesplaymusic
md5sums = acf05f038cc7a1ad42db439c098e6f41
- md5sums = 107bf43817d58d29486823343ea36050
+ md5sums = ade11d60b069c369b57b5d1e09066519
+ md5sums = 426a2f7143ad4d0f5d060ba01e349518
pkgname = yesplaymusic-electron
diff --git a/PKGBUILD b/PKGBUILD
index 84cdd155cc00..bf2cf4462d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=yesplaymusic-electron
pkgver=0.3.7
-pkgrel=1
+pkgrel=2
pkgdesc="A third party music application for Netease Music. Using the system electron"
arch=("any")
url="https://github.com/qier222/YesPlayMusic"
@@ -25,12 +25,17 @@ optdepends=(
'libnotify'
'libappindicator-gtk3'
)
+provides=('yesplaymusic')
+conflicts=('yesplaymusic')
+replaces=('yesplaymusic')
source=(
"YesPlayMusic-${pkgver}.pacman::https://github.com/qier222/YesPlayMusic/releases/download/v${pkgver}/YesPlayMusic-${pkgver}.pacman"
yesplaymusic.desktop
+ yesplaymusic
)
md5sums=('acf05f038cc7a1ad42db439c098e6f41'
- '107bf43817d58d29486823343ea36050')
+ 'ade11d60b069c369b57b5d1e09066519'
+ '426a2f7143ad4d0f5d060ba01e349518')
package() {
cp -r "usr" "${pkgdir}"
@@ -38,4 +43,5 @@ package() {
install -d "${pkgdir}/usr/share"
install -Dm644 -t "${pkgdir}/usr/share/applications" "yesplaymusic.desktop"
install -Dm644 "opt/YesPlayMusic/resources/app.asar" "${pkgdir}/usr/share/yesplaymusic.asar"
+ install -Dm755 "yesplaymusic" "${pkgdir}/usr/bin/yesplaymusic"
}
diff --git a/yesplaymusic b/yesplaymusic
new file mode 100644
index 000000000000..507c7a19bbd2
--- /dev/null
+++ b/yesplaymusic
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+electron /usr/share/yesplaymusic.asar
diff --git a/yesplaymusic.desktop b/yesplaymusic.desktop
index 585835ca209a..e4823739c1e9 100644
--- a/yesplaymusic.desktop
+++ b/yesplaymusic.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Name=YesPlayMusic
-Exec=electron /usr/share/yesplaymusic.asar %U
+Exec=yesplaymusic
Terminal=false
Type=Application
Icon=yesplaymusic