summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhanghua0002022-03-25 21:46:09 +0800
committerzhanghua0002022-03-25 21:46:09 +0800
commitd1f32d180e3574f3233f06745db6cefcfbca3a23 (patch)
tree4d601cf8119eeec2054358f4f8b974bda83a3ec4
parent5063b167c2dfdeb7ca4089f779323702879d57cd (diff)
downloadaur-d1f32d180e3574f3233f06745db6cefcfbca3a23.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c375799ecec..32db6764bb9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yesplaymusic-git
pkgdesc = 高颜值的第三方网易云播放器,支持 Windows / macOS / Linux
pkgver = 0.4.4.beta.1.14.gb1c5873
- pkgrel = 2
+ pkgrel = 3
url = https://music.qier222.com
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 010b2c05fc0f..c20f0b0327e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=yesplaymusic-git
pkgname=(yesplaymusic-git yesplaymusic-electron-git)
pkgver=0.4.4.beta.1.14.gb1c5873
-pkgrel=2
+pkgrel=3
pkgdesc="高颜值的第三方网易云播放器,支持 Windows / macOS / Linux"
arch=("x86_64" "aarch64")
url="https://music.qier222.com"
@@ -16,6 +16,8 @@ source=("git+https://github.com/qier222/YesPlayMusic" "yesplaymusic.desktop" "ye
sha256sums=('SKIP'
'56fb010914c3baad7bde6ccac03d9e92f705652c6f0098547cafbf4fcc613630'
'dc7e893cbea98f0f20b7ffdf18c8462c45069618421ea2ebd40ee34051f68e66')
+_electron=electron13
+
pkgver(){
cd "${srcdir}/YesPlayMusic"
git describe --tags | sed "s/-/./g;s/v//"
@@ -53,7 +55,7 @@ package_yesplaymusic-git(){
install -Dm644 "${srcdir}/yesplaymusic.desktop" "${pkgdir}/usr/share/applications/yesplaymusic.desktop"
}
package_yesplaymusic-electron-git(){
- depends+=("electron13")
+ depends+=("${_electron}")
pkgdesc+=" (with system electrton)"
conflicts+=("yesplaymusic-electron")
provides+=("yesplaymusic-electron")
@@ -72,7 +74,7 @@ package_yesplaymusic-electron-git(){
install -Dm644 dist_electron/linux${_arch}unpacked/resources/app.asar "${pkgdir}/usr/lib/yesplaymusic/yesplaymusic.asar"
install -Dm755 "${srcdir}/yesplaymusic" "${pkgdir}/usr/bin/yesplaymusic"
install -Dm644 "${srcdir}/yesplaymusic.desktop" "${pkgdir}/usr/share/applications/yesplaymusic.desktop"
- sed -i "s/electron/electron13/" "${pkgdir}/usr/bin/yesplaymusic"
+ sed -i "s/electron/${_electron}/" "${pkgdir}/usr/bin/yesplaymusic"
for res in 1024x1024 128x128 16x16 24x24 256x256 32x32 48x48 512x512 64x64
do
install -Dm644 build/icons/${res}.png "${pkgdir}/usr/share/icons/hicolor/${res}/apps/yesplaymusic.png"