summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Dems2021-11-15 14:07:11 +0100
committerMaciej Dems2021-11-15 14:07:11 +0100
commitb5b49f9ac95766886f9eaf824ccc1d5523b698a5 (patch)
treeb9711a74653de6df1f254cf462161d6aec19b2c3
downloadaur-b5b49f9ac95766886f9eaf824ccc1d5523b698a5.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fa4461a5940
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yet-another-spotify-tray-git
+ pkgdesc = Tray icon fot Spotify Linux client application
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/macdems/yet-another-spotify-tray
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = qt5-base
+ depends = libx11
+ depends = dbus
+ provides = spotify-tray
+ conflicts = spotify-tray
+ source = git+https://github.com/macdems/yet-another-spotify-tray.git
+ sha256sums = SKIP
+
+pkgname = yet-another-spotify-tray-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..472582a5e5e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.*
+/yet-another-spotify-tray
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19fe01e83778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Maciej Dems <macdems@gmail.com>
+
+_pkgname=yet-another-spotify-tray
+pkgname=${_pkgname}-git
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Tray icon fot Spotify Linux client application"
+arch=('x86_64')
+url="https://github.com/macdems/${_pkgname}"
+license=('MIT')
+depends=('qt5-base' 'libx11' 'dbus')
+makedepends=('cmake')
+source=("git+https://github.com/macdems/${_pkgname}.git")
+sha256sums=('SKIP')
+provides=('spotify-tray')
+conflicts=('spotify-tray')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s.%s" \
+ $(awk '/project\(yet-another-spotify-tray VERSION (\S+)/ { print $3; }' CMakeLists.txt) \
+ $(git rev-parse --short HEAD)
+}
+
+build() {
+ cmake -B build -S ${_pkgname} \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}