summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Cromer2016-09-10 16:55:12 -0300
committerChris Cromer2016-09-10 16:55:12 -0300
commit53dafe46d60ab1f15eff19c4fd18e0f966cb9883 (patch)
tree7bfd8864c32674611a7340d408efef6a5b4de000
parent8b6a19b67a9312c1c944a4ef068fa02f7d63ba98 (diff)
downloadaur-53dafe46d60ab1f15eff19c4fd18e0f966cb9883.tar.gz
added binary to /usr/bin and added missing depend
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rwxr-xr-xygopro.sh4
3 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 451589d27ce1..9ce53ecb8b7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ygopro-bin
pkgdesc = YGOPRO is a free online dueling system made for playing Yu-Gi-Oh! duels.
pkgver = 1.033.A
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/cromerc/ygopro
install = ygopro-bin.install
arch = x86_64
@@ -11,11 +11,14 @@ pkgbase = ygopro-bin
depends = freetype2
depends = libevent
depends = sfml
+ depends = libgit2
options = !strip
options = emptydirs
backup = opt/ygopro/system.conf
source = https://github.com/cromerc/ygopro/archive/1.033.A-2.tar.gz
+ source = ygopro.sh
sha256sums = f67dc54506f6f41e9463958283ab980fffb364bb10e783a8b46f5ad3b6233c59
+ sha256sums = 706523e0c9732107e889cb20f3eece86096791237a959847bcd1debbdeb09532
pkgname = ygopro-bin
diff --git a/PKGBUILD b/PKGBUILD
index 378b974d0073..b2f06cd481c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
pkgname=ygopro-bin
pkgver=1.033.A
-pkgrel=2
+pkgrel=3
_pkgrel=2
pkgdesc="YGOPRO is a free online dueling system made for playing Yu-Gi-Oh! duels."
arch=('x86_64')
url='https://github.com/cromerc/ygopro'
license=('GPL2')
-depends=('openal' 'openssl' 'freetype2' 'libevent' 'sfml')
+depends=('openal' 'openssl' 'freetype2' 'libevent' 'sfml' 'libgit2')
backup=(opt/ygopro/system.conf)
-source=("https://github.com/cromerc/ygopro/archive/${pkgver}-${_pkgrel}.tar.gz")
-sha256sums=('f67dc54506f6f41e9463958283ab980fffb364bb10e783a8b46f5ad3b6233c59')
+source=("https://github.com/cromerc/ygopro/archive/${pkgver}-${_pkgrel}.tar.gz"
+ ygopro.sh)
+sha256sums=('f67dc54506f6f41e9463958283ab980fffb364bb10e783a8b46f5ad3b6233c59'
+ '706523e0c9732107e889cb20f3eece86096791237a959847bcd1debbdeb09532')
options=('!strip' 'emptydirs')
install=${pkgname}.install
@@ -30,4 +32,6 @@ package() {
cd "$pkgdir/usr/lib"
ln -s libsfml-audio.so.2.4 libsfml-audio.so.2.3
ln -s libsfml-system.so.2.4 libsfml-system.so.2.3
+
+ install -DTm755 ${srcdir}/ygopro.sh ${pkgdir}/usr/bin/ygopro
}
diff --git a/ygopro.sh b/ygopro.sh
new file mode 100755
index 000000000000..cadb05799e83
--- /dev/null
+++ b/ygopro.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/ygopro
+/opt/ygopro/ygopro