summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthflameemperor2019-03-20 19:42:46 -0400
committerthflameemperor2019-03-20 19:42:46 -0400
commitbf723226b49b6e20d3d4bbc972f6ff37c52c185c (patch)
tree2b2742ed20abe5b5ed73e1ca5825fb2cd6d98d59
parentf4d94a267b3ff0161e310a36dc47da86a1f7edfc (diff)
downloadaur-bf723226b49b6e20d3d4bbc972f6ff37c52c185c.tar.gz
removing decks correctly from the output dir
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6a79407b871d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/**
+src/**
+usr/**
+*.zip
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index c6ae0ec0a32c..d4070f8ba023 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: theflameemperor <un.own.cry@gmail.com>
pkgname=ygopro-koishipro
-pkgver=2019.3.6
-pkgrel=5
+pkgver=2019.3.15
+pkgrel=1
_pkgrel=1
zipFile=KoishiPro-linux-full-${pkgver}.zip
pkgdesc="Link compatable ygopro client with AI"
@@ -12,7 +12,7 @@ depends=('mono' 'libevent')
makedepends=('patchelf')
source=("https://github.com/purerosefallen/ygopro/releases/download/$pkgver/$zipFile")
noextract=($zipFile)
-sha256sums=('936ec2c86f4d30e621af807f67e6f2182280c06e92cc98f1162f2e91a96ffdd5')
+sha256sums=('2ae0eccd26f24e3333e31e2baf1f901f07b0c309da6f096bc07a27f7b70f508b')
options=('!strip' 'emptydirs')
prepare(){
@@ -21,7 +21,6 @@ prepare(){
mkdir -p ../usr/share/applications
cp ../koishipro.desktop ../usr/share/applications
unzip -qq -o $zipFile -d $pkgname
- rm -rf ./$pkgname/deck/
patchelf --remove-needed libevent_pthreads-2.0.so.5 ./$pkgname/ygopro
patchelf --add-needed libevent_pthreads.so ./$pkgname/ygopro
patchelf --remove-needed libevent-2.0.so.5 ./$pkgname/ygopro
@@ -31,9 +30,11 @@ prepare(){
package(){
outputDir="$pkgdir/opt/$pkgname"
mkdir -p $outputDir
+ echo $outputDir
cp -r ../usr $pkgdir
cp ../YGOPro.png $outputDir/
cp -dR $pkgname/* $outputDir
find $outputDir -type d -exec chmod 777 {} \;
find $outputDir -type f -exec chmod 777 {} \;
+ rm $outputDir/deck/*
}