summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJef Roosens2022-05-29 13:59:23 +0200
committerJef Roosens2022-05-29 13:59:23 +0200
commit41bc6bde207e25c38180624a17de61aa89efa0f4 (patch)
tree117537797be3de861753f1232423d35afefbc646
downloadaur-41bc6bde207e25c38180624a17de61aa89efa0f4.tar.gz
Added PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31d20e7c68f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = yip-git
+ pkgdesc = Performant, lightweight HTTP server that echoes the client's IP address, written in plain C. (Development version)
+ pkgver = 0.1.2.r0.gdbcdd0d
+ pkgrel = 1
+ url = https://github.com/jenspots/yip
+ arch = x86_64
+ license = AGPL-3.0
+ source = yip-git::git+https://github.com/jenspots/yip#branch=main
+ md5sums = SKIP
+
+pkgname = yip-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19a68f581cc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jef Roosens
+
+pkgbase=yip-git
+pkgname=yip-git
+pkgver=0.1.2.r0.gdbcdd0d
+pkgrel=1
+pkgdesc="Performant, lightweight HTTP server that echoes the client's IP address, written in plain C. (Development version)"
+arch=('x86_64')
+
+url='https://github.com/jenspots/yip'
+license=('AGPL-3.0')
+
+source=("${pkgname}::git+https://github.com/jenspots/yip#branch=main")
+md5sums=('SKIP')
+
+pkgver() {
+ git -C "${pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+
+ gcc -o yip -O3 -lpthread yip.c
+}
+
+package() {
+ install -Dm755 "${pkgname}/yip" "${pkgdir}/usr/bin/yip"
+ install -Dm644 "${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/LICENSE"
+}