summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-29 11:19:13 +1300
committercaltlgin2020-09-29 11:19:13 +1300
commit235a712b8311cf886b33210f0c61bdc512094490 (patch)
treeae513fb28f83e60ed9e188c78c63312f52a38882
downloadaur-235a712b8311cf886b33210f0c61bdc512094490.tar.gz
Add to AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b385403e7d75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = yishu
+ pkgdesc = Bespoke and simple Todo.txt client
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/lainsce/yishu/
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ source = yishu-1.2.5.tar.gz::https://github.com/lainsce/yishu//archive/1.2.5.tar.gz
+ sha256sums = fbb1ebcf16672b818cb92f7022c1d9e5e17bdb1b776612535e0af6a8abd75a39
+
+pkgname = yishu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7ce3f359d82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='yishu'
+pkgver=1.2.5
+pkgrel=1
+pkgdesc='Bespoke and simple Todo.txt client'
+arch=('x86_64')
+url='https://github.com/lainsce/yishu/'
+license=('GPL3')
+depends=('granite')
+makedepends=('meson' 'vala')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('fbb1ebcf16672b818cb92f7022c1d9e5e17bdb1b776612535e0af6a8abd75a39')
+
+build() {
+ arch-meson "${pkgname}-${pkgver}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
+}
+
+# vim: ts=2 sw=2 et: