summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-07-17 11:53:47 +0200
committerChristopher Arndt2019-07-17 11:53:47 +0200
commit12e6114879713ec179afa753f872e01510aa8534 (patch)
treeed8cd68ef6fd645e129f0226a57a514690d04890
downloadaur-12e6114879713ec179afa753f872e01510aa8534.tar.gz
Add new package 'ykchorus'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD26
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71375ebb5f68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ykchorus
+ pkgdesc = A stereo dual-chorus audio effect
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/SpotlightKid/ykchorus
+ arch = i686
+ arch = x86_64
+ groups = ladspa-plugins
+ groups = lv2-plugins
+ groups = vst-plugins
+ license = GPL2
+ depends = libglvnd
+ optdepends = jack: stand-alone JACK client program
+ source = https://github.com/SpotlightKid/ykchorus/releases/download/v0.2.2/ykchorus-v0.2.2-source.tar.gz
+ md5sums = 5763a1afa37e7cca6367b6c610b815ef
+
+pkgname = ykchorus
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..593c7a85560d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+.AURINFO
+ykchorus-*.tar.xz
+ykchorus-*.src.tar.gz
+ykchorus*-source.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2848b8758151
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname="ykchorus"
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="A stereo dual-chorus audio effect"
+arch=('i686' 'x86_64')
+url="https://github.com/SpotlightKid/${pkgname}"
+license=('GPL2')
+depends=('libglvnd')
+optdepends=('jack: stand-alone JACK client program')
+groups=('ladspa-plugins' 'lv2-plugins' 'vst-plugins')
+source=("https://github.com/SpotlightKid/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}-source.tar.gz")
+md5sums=('5763a1afa37e7cca6367b6c610b815ef')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ make DESTDIR="${pkgdir}" install
+}