summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZaZam2020-10-28 16:16:34 +0200
committerZaZam2020-10-28 16:16:34 +0200
commit1667a190e28482ebf5eb39ab0f9c652f2af9a39e (patch)
treeec6e7310178169785560f95d1cc47e26739ad212
parent3ba8f9f9c7ad9b81915c76e134fb1f35573d167a (diff)
downloadaur-1667a190e28482ebf5eb39ab0f9c652f2af9a39e.tar.gz
version 20201022 and removed unnecessary patch file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--python-attrs.patch12
3 files changed, 5 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2be31439a223..552ac844f7d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yle-dl
pkgdesc = Download video and audio from YLE Areena.
- pkgver = 20200807
+ pkgver = 20201022
pkgrel = 1
url = http://aajanki.github.io/yle-dl/
arch = any
@@ -14,8 +14,8 @@ pkgbase = yle-dl
depends = python-requests
optdepends = youtube-dl: an alternative downloader backend to AdobeHDS.php
optdepends = wget: for some rare streams
- source = yle-dl-20200807.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-20200807.tar.gz
- sha256sums = 168709513671525e4adb5d733c563a297a24a7324b369301c7f1ffbb6817e938
+ source = yle-dl-20201022.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-20201022.tar.gz
+ sha256sums = 44b0b99e78d849b2f30583dd3b2d3a4ad55931642f6cdb9ead34493f15b9a0cf
pkgname = yle-dl
diff --git a/PKGBUILD b/PKGBUILD
index a816a04b3dd6..b593e6bb88e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor sumt <sumt at sci dot fi>
pkgname=yle-dl
-pkgver=20200807
+pkgver=20201022
pkgrel=1
pkgdesc="Download video and audio from YLE Areena."
arch=('any')
@@ -20,7 +20,7 @@ optdepends=('youtube-dl: an alternative downloader backend to AdobeHDS.php'
'wget: for some rare streams')
makedepends=('python-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-${pkgver}.tar.gz")
-sha256sums=('168709513671525e4adb5d733c563a297a24a7324b369301c7f1ffbb6817e938')
+sha256sums=('44b0b99e78d849b2f30583dd3b2d3a4ad55931642f6cdb9ead34493f15b9a0cf')
build() {
diff --git a/python-attrs.patch b/python-attrs.patch
deleted file mode 100644
index 7ec08a8bbf3a..000000000000
--- a/python-attrs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text yle-dl-20190614/setup.py yle-dl-20190614.new/setup.py
---- yle-dl-20190614/setup.py
-+++ yle-dl-20190614.new/setup.py
-@@ -39,7 +39,7 @@
- include_package_data=True,
- install_requires=[
- 'pycryptodomex', 'requests', 'lxml', 'future', 'mini-amf',
-- 'attrs >= 18.1.0, < 19.2.0', 'ConfigArgParse >= 0.13.0'
-+ 'attrs >= 18.1.0, < 19.4.0', 'ConfigArgParse >= 0.13.0'
- ] + ssl_sni_requires,
- extras_require = {
- 'youtubedl-backend': ['youtube_dl']