summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZaZam2019-04-08 11:18:19 +0300
committerZaZam2019-04-08 11:18:19 +0300
commit27c8567668b74280b07f32ff4fbb4eedf476d897 (patch)
tree27b9126c48a26b1a968cdc0824079c7f7d0286d6
parent0aec1fd852fb06ae173bf4c3339d42c30c493526 (diff)
downloadaur-27c8567668b74280b07f32ff4fbb4eedf476d897.tar.gz
version 20190331
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--python-attrs.patch12
3 files changed, 8 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8f702d303c3..1eb42dd86f46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yle-dl
pkgdesc = Download video and audio from YLE Areena.
- pkgver = 20190203
- pkgrel = 2
+ pkgver = 20190331
+ pkgrel = 1
url = http://aajanki.github.io/yle-dl/
arch = any
license = GPL3
@@ -19,10 +19,8 @@ pkgbase = yle-dl
optdepends = rtmpdump: for downloading some Elävä Arkisto streams
optdepends = youtube-dl: an alternative downloader backend to AdobeHDS.php
optdepends = wget: for some rare streams
- source = yle-dl-20190203.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-20190203.tar.gz
- source = python-attrs.patch
- sha256sums = 81c3096162657d3d8e9e9a2b4d277261b8be4c8696a31505b1f9b6352cf9996f
- sha256sums = f34434da4ff3303b51c52b729f9180630505f379c1bb6261887dcf86f75fb9a7
+ source = yle-dl-20190331.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-20190331.tar.gz
+ sha256sums = 2664416b44c33188bd41b7bef70ebcf1d12a74ecae4a16bfc60965340534bfdd
pkgname = yle-dl
diff --git a/PKGBUILD b/PKGBUILD
index beade95c986e..5c2f1ceb7cd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: ZaZam <zazaamm ät gmail dt com>
pkgname=yle-dl
-pkgver=20190203
-pkgrel=2
+pkgver=20190331
+pkgrel=1
pkgdesc="Download video and audio from YLE Areena."
arch=('any')
url="http://aajanki.github.io/yle-dl/"
@@ -24,14 +24,8 @@ optdepends=('php: for downloading live TV and certain news broadcasts'
'youtube-dl: an alternative downloader backend to AdobeHDS.php'
'wget: for some rare streams')
makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-${pkgver}.tar.gz" 'python-attrs.patch')
-sha256sums=('81c3096162657d3d8e9e9a2b4d277261b8be4c8696a31505b1f9b6352cf9996f'
- 'f34434da4ff3303b51c52b729f9180630505f379c1bb6261887dcf86f75fb9a7')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i "${srcdir}/python-attrs.patch"
-}
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-${pkgver}.tar.gz")
+sha256sums=('2664416b44c33188bd41b7bef70ebcf1d12a74ecae4a16bfc60965340534bfdd')
build() {
cd $pkgname-$pkgver
diff --git a/python-attrs.patch b/python-attrs.patch
deleted file mode 100644
index 6a5baae984ad..000000000000
--- a/python-attrs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text yle-dl-20190203.orig/setup.py yle-dl-20190203.new/setup.py
---- yle-dl-20190203.orig/setup.py 2019-01-26 13:24:19.000000000 +0200
-+++ yle-dl-20190203.new/setup.py 2019-03-23 10:29:24.209744725 +0200
-@@ -39,7 +39,7 @@
- include_package_data=True,
- install_requires=[
- 'pycryptodomex', 'requests', 'lxml', 'future', 'mini-amf',
-- 'attrs >= 18.1.0, < 18.3.0', 'ConfigArgParse >= 0.13.0'
-+ 'attrs >= 18.1.0, < 19.2.0', 'ConfigArgParse >= 0.13.0'
- ] + ssl_sni_requires,
- extras_require = {
- 'youtubedl-backend': ['youtube_dl']