summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerard Salvatella2021-02-10 23:55:54 +0100
committerGerard Salvatella2021-02-10 23:55:54 +0100
commitdab5e88dfd9308cb9c3e9f1e9945a0e632fc56ff (patch)
treef4b85368792b9260bc447738b1a83e84f7f70d6f
downloadaur-dab5e88dfd9308cb9c3e9f1e9945a0e632fc56ff.tar.gz
add first version of the package
This is the initial commit for the yoctolib-cmdlines package. Include the PKGBUILD and .SRCINFO files.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0a1676a06dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = yoctolib-cmdlines
+ pkgdesc = Cli binaries for Yoctopuce USB devices
+ pkgver = 43781
+ pkgrel = 1
+ url = https://www.yoctopuce.com
+ arch = x86_64
+ license = GPL
+ source = https://www.yoctopuce.com/FR/downloads/Cmdlines.linux_intel.43781.zip
+ sha256sums = SKIP
+
+pkgname = yoctolib-cmdlines
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5af8ba4caf42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gerard Salvatella <mail@gerardsalvatella.com>
+
+pkgname=yoctolib-cmdlines
+pkgver=43781
+pkgrel=1
+epoch=
+pkgdesc="Cli binaries for Yoctopuce USB devices"
+arch=('x86_64')
+url="https://www.yoctopuce.com"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://www.yoctopuce.com/FR/downloads/Cmdlines.linux_intel.${pkgver}.zip"
+ )
+noextract=()
+sha256sums=("SKIP"
+ )
+validpgpkeys=()
+
+package() {
+ install -d "${pkgdir}/usr/bin/"
+ install -Dm755 Binaries/linux/64bits/* "${pkgdir}/usr/bin"
+}