summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2018-08-15 13:36:33 +0200
committerFrank Siegert2018-08-15 13:36:37 +0200
commitda3f3c2be80efdaf351d619f6fb4ae5ae507588f (patch)
treece129e02179cd65eb55fbc57b562d1626886db16
parente7b3a9ada648a22f7cc3e695c01a5141920ef471 (diff)
downloadaur-da3f3c2be80efdaf351d619f6fb4ae5ae507588f.tar.gz
Update to 1.7.1-1: New upstream version, and move to Python3 (with Python2 module built optionally)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54208d9d86c9..db6cd5844570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
# Generated by mksrcinfo v8
-# Mon Jun 19 12:42:43 UTC 2017
+# Wed Aug 15 11:36:33 UTC 2018
pkgbase = yoda
pkgdesc = A particle physics package for data analysis (specifically histogramming) classes.
- pkgver = 1.6.7
+ pkgver = 1.7.1
pkgrel = 1
url = http://yoda.hepforge.org
arch = x86_64
arch = i686
- license = GPL2
- makedepends = cython2
- makedepends = autoconf
- makedepends = libtool
- makedepends = automake
- depends = python2
- source = http://www.hepforge.org/archive/yoda/YODA-1.6.7.tar.gz
- md5sums = eac1db159608d018ca9ae13c6333354f
+ license = GPL3
+ makedepends = cython
+ depends = python
+ optdepends = python2: For Python2 module in addition to Python3
+ source = http://www.hepforge.org/archive/yoda/YODA-1.7.1.tar.gz
+ md5sums = 0ce3cbfd210f3231dc88161e8324863c
pkgname = yoda
diff --git a/PKGBUILD b/PKGBUILD
index 3a7fd6baa0e3..f47acf65dceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=yoda
-pkgver=1.6.7
+pkgver=1.7.1
pkgrel=1
pkgdesc="A particle physics package for data analysis (specifically histogramming) classes."
arch=('x86_64' 'i686')
url="http://yoda.hepforge.org"
-license=('GPL2')
-depends=('python2')
-makedepends=('cython2' 'autoconf' 'libtool' 'automake')
+license=('GPL3')
+depends=('python')
+optdepends=('python2: For Python2 module in addition to Python3')
+makedepends=('cython')
source=(http://www.hepforge.org/archive/yoda/YODA-$pkgver.tar.gz)
-md5sums=('eac1db159608d018ca9ae13c6333354f')
-
-prepare() {
- cd "$srcdir/YODA-$pkgver"
- sed -e 's/\/usr\/bin\/env python$/\/usr\/bin\/env python2/g' -i bin/* pyext/yoda/mktemplates pyext/setup.py.in
- sed -e 's/cython /cython2 /g' -i pyext/yoda/Makefile.am
-}
+md5sums=('0ce3cbfd210f3231dc88161e8324863c')
build() {
cd "$srcdir/YODA-$pkgver"
- export PYTHON=/usr/bin/python2
- autoreconf -i
+ ## need to rebuild Python extension code with up-to-date Cython for Python 3.7
+ ## will eventually be fixed upstream
+ touch pyext/yoda/*.pyx
./configure --prefix=/usr
make
}
@@ -28,6 +24,13 @@ build() {
package() {
cd "$srcdir/YODA-$pkgver"
make DESTDIR="$pkgdir/" install
+
+ # If python2 is present, also build a library for it
+ if [ -x /usr/bin/python2 ]; then
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr
+ make DESTDIR="$pkgdir/" install
+ fi
+
mkdir -p $pkgdir/etc/bash_completion.d
mv $pkgdir/usr/share/YODA/yoda-completion $pkgdir/etc/bash_completion.d
}