summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2018-08-16 13:45:56 +0200
committerFrank Siegert2018-08-16 13:46:18 +0200
commit89123688dedab5bd29c6e5801b0c528b886fc8d1 (patch)
tree12ce26f1002880fd5334cdc22d8dd339bf4c401e
parented2f05f1b614dc3bec605c46c851df1958f22449 (diff)
downloadaur-89123688dedab5bd29c6e5801b0c528b886fc8d1.tar.gz
Update to Python3.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 394471f9153a..27d0e3afb2c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Aug 16 11:45:56 UTC 2018
pkgbase = yoda-hg
pkgdesc = A particle physics package for data analysis (specifically histogramming) classes -- latest build from hg-repo.
- pkgver = r1060.63c03a9d5e8f
+ pkgver = r1479.e335e6743a5e
pkgrel = 1
url = http://yoda.hepforge.org
arch = x86_64
arch = i686
- license = GPL2
- makedepends = cython2
- makedepends = boost
- makedepends = mercurial
- makedepends = autoconf
- makedepends = libtool
- makedepends = automake
- depends = python2
+ license = GPL3
+ makedepends = cython
+ depends = python
+ optdepends = python2: For Python2 module in addition to Python3
provides = yoda
conflicts = yoda
source = hg+https://yoda.hepforge.org/hg/yoda
diff --git a/PKGBUILD b/PKGBUILD
index c873eeb7af8b..286fadb0cdb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=yoda-hg
-pkgver=r1060.63c03a9d5e8f
+pkgver=r1479.e335e6743a5e
pkgrel=1
pkgdesc="A particle physics package for data analysis (specifically histogramming) classes -- latest build from hg-repo."
arch=('x86_64' 'i686')
url="http://yoda.hepforge.org"
-license=('GPL2')
+license=('GPL3')
+depends=('python')
+optdepends=('python2: For Python2 module in addition to Python3')
+makedepends=('cython')
conflicts=('yoda')
provides=('yoda')
-depends=('python2')
-makedepends=('cython2' 'boost' 'mercurial' 'autoconf' 'libtool' 'automake')
source=('hg+https://yoda.hepforge.org/hg/yoda')
md5sums=('SKIP')
-prepare() {
- cd "$srcdir/yoda"
- sed -e 's/\/usr\/bin\/env python$/\/usr\/bin\/env python2/g' -i bin/* pyext/yoda/mktemplates pyext/setup.py.in
- sed -e 's/cython /cython2 /g' -i pyext/yoda/Makefile.am
-}
-
build() {
cd "$srcdir/yoda"
- export PYTHON=/usr/bin/python2
autoreconf -i
+ ## need to rebuild Python extension code with up-to-date Cython for Python 3.7
+ ## will eventually be fixed upstream
+ touch pyext/yoda/*.pyx
./configure --prefix=/usr
make
}
@@ -30,6 +27,13 @@ build() {
package() {
cd "$srcdir/yoda"
make DESTDIR="$pkgdir/" install
+
+ # If python2 is present, also build a library for it
+ if [ -x /usr/bin/python2 ]; then
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr
+ make DESTDIR="$pkgdir/" install
+ fi
+
mkdir -p $pkgdir/etc/bash_completion.d
mv $pkgdir/usr/share/YODA/yoda-completion $pkgdir/etc/bash_completion.d
}