summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhensur2018-01-14 15:24:32 +0100
committerhensur2018-01-14 15:28:15 +0100
commit5b25c32edd8a5b1d12cc3b31995f37f6316de202 (patch)
treeb6c2f2fd5cee8c4bba7f55da5ece8853c2c8e950
downloadaur-5b25c32edd8a5b1d12cc3b31995f37f6316de202.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a104deae8e6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = yoga370d-git
+ pkgdesc = A python daemon which automatically enables tablet mode on the Thinkpad Yoga 370. This means switching off the TouchPad and TrackPoint. The script can also disable the Finger Input if the Pen is in use. It will optionally rotate the screen.
+ pkgver = r18.37e99a7
+ pkgrel = 1
+ url = https://github.com/hensur/yoga370d
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = xorg-xrandr
+ depends = acpid
+ depends = python-dbus
+ depends = iio-sensor-proxy
+ depends = python-docopt
+ depends = xorg-xinput
+ depends = xf86-input-wacom
+ depends = python
+ source = yoga370d::git+https://github.com/hensur/yoga370d
+ md5sums = SKIP
+
+pkgname = yoga370d-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca4eb2f1dfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: hensur <me@hensur.de>
+
+pkgname='yoga370d-git'
+_pkgname='yoga370d'
+pkgver=r18.37e99a7
+pkgrel=1
+pkgdesc='A python daemon which automatically enables tablet mode on the Thinkpad Yoga 370. This means switching off the TouchPad and TrackPoint. The script can also disable the Finger Input if the Pen is in use. It will optionally rotate the screen.'
+url="https://github.com/hensur/yoga370d"
+source=('yoga370d::git+https://github.com/hensur/yoga370d')
+license=('GPL3')
+arch=('any')
+depends=('xorg-xrandr' 'acpid' 'python-dbus' 'iio-sensor-proxy' 'python-docopt' 'xorg-xinput' 'xf86-input-wacom' 'python')
+md5sums=('SKIP')
+makedepends=('git')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ # yoga370d binary
+ install -Dm755 "yoga370d" "${pkgdir}/usr/local/bin/yoga370d"
+
+ # ThinkPad Yoga Desktop File
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+}