summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Libert2023-06-21 15:48:08 +0200
committerBart Libert2023-06-21 15:48:08 +0200
commit3f433d14ddfaa3fc83cc4a58cbde27cdc2ef3e85 (patch)
tree9b141ffc32f7b06ebd7a25e49d5dbf18026bd8ad
downloadaur-3f433d14ddfaa3fc83cc4a58cbde27cdc2ef3e85.tar.gz
initial version
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore1
-rw-r--r--.pre-commit-config.yaml19
-rw-r--r--PKGBUILD37
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c39595b1ec4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = yojenkins
+ pkgdesc = A CLI tool to interface with Jenkins
+ pkgver = 0.0.85
+ pkgrel = 1
+ url = https://www.yojenkins.com/
+ arch = any
+ license = GPL3
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = bash
+ depends = python
+ depends = python-click
+ depends = python-click-help-colors
+ depends = python-coloredlogs
+ depends = python-docker
+ depends = python-json2xml
+ depends = python-python-jenkins
+ depends = python-requests
+ depends = python-requests-futures
+ depends = python-simpleaudio
+ depends = python-toml
+ depends = python-urllib3
+ depends = python-xmltodict
+ depends = python-yaml
+ depends = python-yaspin
+ source = https://files.pythonhosted.org/packages/py3/y/yojenkins/yojenkins-0.0.85-py3-none-any.whl
+ sha512sums = 23088d39e0290c3c041799bd9e68ff4b003a5c750b7756b0e6420c266d524b6a9809b87cec94a263a7214a73e1774c2695bb0e1d66469c992e2d094d851390fe
+
+pkgname = yojenkins
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..734c421e2676
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,19 @@
+---
+repos:
+ - repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.4.0
+ hooks:
+ - id: check-added-large-files
+ - id: check-case-conflict
+ - id: check-vcs-permalinks
+ - id: destroyed-symlinks
+ - id: detect-private-key
+ - id: end-of-file-fixer
+ - id: mixed-line-ending
+ - id: trailing-whitespace
+ - repo: https://github.com/edlanglois/pkgbuild-hooks
+ rev: v0.2.0
+ hooks:
+ - id: srcinfo-fixer
+ - id: verify-srcinfo-checksums
+default_install_hook_types: [pre-commit, commit-msg]
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47e02e854cf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Bart Libert <bart plus aur at libert dot email>
+
+pkgname=yojenkins
+pkgver=0.0.85
+pkgrel=1
+pkgdesc="A CLI tool to interface with Jenkins"
+arch=('any')
+url="https://www.yojenkins.com/"
+license=('GPL3')
+makedepends=('python-setuptools') # unless it only requires distutils
+depends=(
+ 'bash'
+ 'python'
+ 'python-click'
+ 'python-click-help-colors'
+ 'python-coloredlogs'
+ 'python-docker'
+ 'python-json2xml'
+ 'python-python-jenkins'
+ 'python-requests'
+ 'python-requests-futures'
+ 'python-simpleaudio'
+ 'python-toml'
+ 'python-urllib3'
+ 'python-xmltodict'
+ 'python-yaml'
+ 'python-yaspin'
+ )
+_wheel=${pkgname//-/_}-$pkgver-py3-none-any.whl
+source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
+sha512sums=('23088d39e0290c3c041799bd9e68ff4b003a5c750b7756b0e6420c266d524b6a9809b87cec94a263a7214a73e1774c2695bb0e1d66469c992e2d094d851390fe')
+
+makedepends=(python-installer python-wheel)
+
+package() {
+ python -m installer --destdir="$pkgdir" $_wheel
+}