summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Schmidt2020-10-02 13:55:42 +0200
committerTobias Schmidt2020-10-02 13:55:42 +0200
commitc68f470f03e4cf8f9ce41317af55ec18272b9183 (patch)
treed239527f0a9ae223a7c790074175d08de5df3646
parent6ace5d107a897e35ee57ae0bddd9e859d7364219 (diff)
downloadaur-c68f470f03e4cf8f9ce41317af55ec18272b9183.tar.gz
Update and split yopass 10.0.0
Provides split packages for both yopass and yopass-server.
-rw-r--r--CHANGELOG.md8
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 14 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5b32add55c5f..044751813042 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,11 @@
+## 10.0.0 (2020-10-02)
+
+Yopass CLI support was added: <https://github.com/jhaals/yopass/pull/580>.
+Yopass have had several CLIs for creating secrets over the years but this is the first official which is hosted in the same repository.
+
+Binaries have changed slightly so yopass is now the CLI and yopass-server will run the regular server.
+There won't be a difference for those running yopass in Docker since the entrypoint will remain the same.
+
## 9.0.0 (2020-09-03)
* #573 Add file upload to the navigation bar file_cabinet
diff --git a/PKGBUILD b/PKGBUILD
index d2f751272096..5823bdcb5025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
# Maintainer: Tobias Schmidt <tobidt@gmail.com>
-pkgname=yopass
-pkgver=9.0.0
+pkgbase=yopass
+pkgname=(yopass yopass-server)
+pkgver=10.0.0
pkgrel=1
pkgdesc="Secure sharing for secrets, passwords and files"
url="https://yopass.se"
arch=("x86_64")
license=("Apache")
makedepends=("go")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/jhaals/yopass/archive/$pkgver.tar.gz")
-sha512sums=('ef452b392e3e9f261fdae8ea6358a3365ff5b6a8346585935e7559d426356253a9ae99168d12fd564fffb091c21927f9db3a5ec245691ade604cc90ed8a56f52')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/jhaals/yopass/archive/$pkgver.tar.gz")
+sha512sums=('db91b756af69600524767422906e9915d0bbdce2bcc4c846945f0b5ab85efdff26a70d479696e154541ec504b6b364b2b8b39224667c88165b1e6cd1868bc8d7')
changelog="CHANGELOG.md"
-build() {
- cd "$pkgname-$pkgver"
- go build -buildmode=pie -trimpath -mod=readonly -modcacherw -o "$pkgname" ./cmd/yopass
-}
-
check() {
- cd "$pkgname-$pkgver"
+ cd "$pkgbase-$pkgver"
go test ./...
}
-package() {
- cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+_package() {
+ local _pkgname=$1
+ cd "$pkgbase-$pkgver"
+ go build -buildmode=pie -trimpath -mod=readonly -modcacherw -o "$_pkgname" "./cmd/$_pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+package_yopass() {
+ _package yopass
+}
+
+package_yopass-server() {
+ _package yopass-server
}