summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-06 15:50:25 +0800
committerzxp198210052023-06-06 15:50:25 +0800
commit17a52da60b06089c39f50f411cdafac0dfd5bd78 (patch)
tree3141d5bf475f7f2d02c45140267fc93ccf95f90d
parent168c982636b1f8ced6cbd72eeee0faf3254097be (diff)
downloadaur-17a52da60b06089c39f50f411cdafac0dfd5bd78.tar.gz
update to 0.1.179
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cae642c6ff21..584e756859fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,22 @@
pkgbase = yor-bin
pkgdesc = Extensible auto-tagger for your IaC files. The ultimate way to link entities in the cloud back to the codified resource which created it.
- pkgver = 0.1.178
+ pkgver = 0.1.179
pkgrel = 1
url = https://www.yor.io/
+ arch = armv7h
+ arch = aarch64
+ arch = i686
arch = x86_64
license = Apache
depends = glibc
options = !strip
- source = yor-0.1.178.tar.gz::https://github.com/bridgecrewio/yor/releases/download/0.1.178/yor_0.1.178_linux_amd64.tar.gz
- sha256sums = 1d2bcf5f7f3701bea960f298375c0ffdff90ecc2287d1deda042b48574b82533
+ source_armv7h = yor-0.1.179-armv7h.tar.gz::https://github.com/bridgecrewio/yor/releases/download/0.1.179/yor_0.1.179_linux_armv7.tar.gz
+ sha256sums_armv7h = 213de5807bfd66de6af37984ef88883579b693edaf9dfa53ed11e22c04fb7490
+ source_aarch64 = yor-0.1.179-aarch64.tar.gz::https://github.com/bridgecrewio/yor/releases/download/0.1.179/yor_0.1.179_linux_arm64.tar.gz
+ sha256sums_aarch64 = ca211aa7afee95839221c1f287d5c98c1bbfbacf5774266d58ef964eed6d7996
+ source_i686 = yor-0.1.179-i686.tar.gz::https://github.com/bridgecrewio/yor/releases/download/0.1.179/yor_0.1.179_linux_386.tar.gz
+ sha256sums_i686 = e14aa355988f215b92aacb6e853731cfc63738272c6e2cf218c68c8892a83445
+ source_x86_64 = yor-0.1.179-x86_64.tar.gz::https://github.com/bridgecrewio/yor/releases/download/0.1.179/yor_0.1.179_linux_amd64.tar.gz
+ sha256sums_x86_64 = 26209c7d0f4a0f8afc99dddad2d9c241f93525bfe4d1d472be9bb98ec847cef8
pkgname = yor-bin
diff --git a/PKGBUILD b/PKGBUILD
index de9c7440a6c7..67dd7e829e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Contributor: Paul Nicholson <brenix@gmail.com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=yor-bin
-pkgver=0.1.178
+pkgver=0.1.179
pkgrel=1
pkgdesc="Extensible auto-tagger for your IaC files. The ultimate way to link entities in the cloud back to the codified resource which created it."
-arch=('x86_64')
+arch=('armv7h' 'aarch64' 'i686' 'x86_64')
url="https://www.yor.io/"
_githuburl="https://github.com/bridgecrewio/yor"
license=('Apache')
depends=('glibc')
options=(!strip)
-source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_linux_amd64.tar.gz")
-sha256sums=('1d2bcf5f7f3701bea960f298375c0ffdff90ecc2287d1deda042b48574b82533')
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_linux_armv7.tar.gz")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_linux_arm64.tar.gz")
+source_i686=("${pkgname%-bin}-${pkgver}-i686.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_linux_386.tar.gz")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_linux_amd64.tar.gz")
+sha256sums_armv7h=('213de5807bfd66de6af37984ef88883579b693edaf9dfa53ed11e22c04fb7490')
+sha256sums_aarch64=('ca211aa7afee95839221c1f287d5c98c1bbfbacf5774266d58ef964eed6d7996')
+sha256sums_i686=('e14aa355988f215b92aacb6e853731cfc63738272c6e2cf218c68c8892a83445')
+sha256sums_x86_64=('26209c7d0f4a0f8afc99dddad2d9c241f93525bfe4d1d472be9bb98ec847cef8')
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/usr/bin"