summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-04-25 10:27:05 +0800
committerzxp198210052023-04-25 10:27:05 +0800
commit7ae2b1e9ac3e3e799296092c58e90b9fd78171a7 (patch)
treee7b73b33a84bca92c47f496fad9694a24bc872e8
parentc56a00a8579747a5e36817769bba9d0a25dfc3c0 (diff)
downloadaur-7ae2b1e9ac3e3e799296092c58e90b9fd78171a7.tar.gz
update to 0.1.171
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea22a1a28238..445b99148fda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = yor-bin
- pkgdesc = Extensible auto-tagger for your IaC files.
- pkgver = 0.1.150
+ pkgdesc = Extensible auto-tagger for your IaC files. The ultimate way to link entities in the cloud back to the codified resource which created it.
+ pkgver = 0.1.171
pkgrel = 1
- url = https://github.com/bridgecrewio/yor
+ url = https://www.yor.io/
arch = x86_64
- license = Apache
- source = https://github.com/bridgecrewio/yor/releases/download/0.1.150/yor_0.1.150_linux_amd64.tar.gz
- sha256sums = 687ce1bb90742201345791f9fc508cfac65635fcb4ffa2bc03496e8835331971
+ license = Apache2
+ depends = glibc
+ options = !strip
+ source = yor-0.1.171.tar.gz::https://github.com/bridgecrewio/yor/releases/download/0.1.171/yor_0.1.171_linux_amd64.tar.gz
+ sha256sums = 71e5dfba58f7f9de233156510b9bb1f14a6686bd8c927a0bc0835772e3a60e47
pkgname = yor-bin
diff --git a/PKGBUILD b/PKGBUILD
index de22a02f5bc3..6ede8456ae2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# $Id$
# Contributor: Paul Nicholson <brenix@gmail.com>
-
-_name=yor
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=yor-bin
-pkgver=0.1.150
+pkgver=0.1.171
pkgrel=1
-pkgdesc="Extensible auto-tagger for your IaC files."
+pkgdesc="Extensible auto-tagger for your IaC files. The ultimate way to link entities in the cloud back to the codified resource which created it."
arch=('x86_64')
-url="https://github.com/bridgecrewio/yor"
-license=('Apache')
-source=("${url}/releases/download/${pkgver}/${_name}_${pkgver}_linux_amd64.tar.gz")
-sha256sums=('687ce1bb90742201345791f9fc508cfac65635fcb4ffa2bc03496e8835331971')
+url="https://www.yor.io/"
+_githuburl="https://github.com/bridgecrewio/yor"
+license=('Apache2')
+depends=('glibc')
+options=(!strip)
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('71e5dfba58f7f9de233156510b9bb1f14a6686bd8c927a0bc0835772e3a60e47')
package() {
- cd "${srcdir}"
- install -Dm755 ${srcdir}/${_name} ${pkgdir}/usr/bin/${_name}
-}
+ install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file