summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancois Rigaut2020-11-15 23:29:45 +1100
committerFrancois Rigaut2020-11-15 23:29:45 +1100
commit395ae7cebafc3f1f8d0a020cf6a0c3a325a2a676 (patch)
tree00b011f87ca13f29ffc72053f2d90d356da256f3
downloadaur-395ae7cebafc3f1f8d0a020cf6a0c3a325a2a676.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e62623d21bcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = yorick-usleep
+ pkgdesc = usleep function
+ pkgver = 20201115
+ pkgrel = 1
+ url = https://github.com/frigaut/yorick-usleep
+ arch = i686
+ arch = x86_64
+ groups = science
+ groups = yorick-all
+ license = GPL
+ makedepends = yorick
+ depends = yorick
+
+pkgname = yorick-usleep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bd11706cf61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Francois Rigaut <frigaut at gmail dot com>
+
+pkgname=yorick-usleep
+pkgver=20201115
+pkgrel=1
+pkgdesc="usleep function"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://github.com/frigaut/yorick-usleep"
+groups=('science' 'yorick-all')
+depends=('yorick')
+makedepends=('yorick')
+
+_gitroot="git://github.com/frigaut/yorick-usleep.git"
+_gitname="yorick-usleep"
+
+build() {
+ cd ${srcdir}
+ msg "Connecting to git repo..."
+ if [ -d ${srcdir}/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting script install..."
+
+ git clone $_gitname $_gitname-build
+ cd ${srcdir}/$_gitname-build
+
+ yorick -batch make.i
+ make
+}
+
+package() {
+ cd ${srcdir}/$_gitname-build
+ make DESTDIR=${pkgdir} install
+}