summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIldus Kurbangaliev2022-03-17 14:03:18 +0500
committerIldus Kurbangaliev2022-03-17 14:03:18 +0500
commit32dae04de16e0a64dc3332d6034d35623e1112df (patch)
tree8d48fb728f59545b677e104f9812606546cd3a54
downloadaur-32dae04de16e0a64dc3332d6034d35623e1112df.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..314b59fea65b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = yosys-uhdm-plugin
+ pkgdesc = UDHM plugin for Yosys (SystemVerilog support)
+ pkgver = d13a016
+ pkgrel = 1
+ url = https://github.com/antmicro/yosys-uhdm-plugin-integration/releases
+ arch = x86_64
+ license = ISC License
+ makedepends = jq
+ makedepends = curl
+ makedepends = wget
+ depends = oss-cad-suite-build-bin
+ provides = yosys-uhdm-plugin
+ source = https://api.github.com/repos/antmicro/yosys-uhdm-plugin-integration/releases/latest
+ sha512sums = SKIP
+
+pkgname = yosys-uhdm-plugin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3f2df15f74c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ildus Kurbangaliev <i.kurbangaliev@gmail.com>
+
+pkgname=yosys-uhdm-plugin
+pkgver=d13a016
+pkgrel=1
+pkgdesc='UDHM plugin for Yosys (SystemVerilog support)'
+arch=('x86_64')
+url='https://github.com/antmicro/yosys-uhdm-plugin-integration/releases'
+license=('ISC License')
+provides=('yosys-uhdm-plugin')
+depends=('oss-cad-suite-build-bin')
+makedepends=('jq' 'curl' 'wget')
+
+source=("https://api.github.com/repos/antmicro/yosys-uhdm-plugin-integration/releases/latest")
+sha512sums=('SKIP')
+
+prepare() {
+ cat latest | jq '.assets[1]["browser_download_url"]' | xargs wget -O - | tar -xz
+}
+
+pkgver() {
+ cat latest | jq '.tag_name' | grep -Eo '[^-"]*' | head -1
+}
+
+package() {
+ YOSYS_DATDIR=$(yosys-config --datdir)
+ YOSYS_PLUGIN_DIR=$pkgdir/$YOSYS_DATDIR/plugins
+ UHDM_PLUGIN_PATH=$srcdir/image/share/yosys/plugins/uhdm.so
+
+ mkdir -p $YOSYS_PLUGIN_DIR
+ cp -v $UHDM_PLUGIN_PATH $pkdir/$YOSYS_PLUGIN_DIR
+}