summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgdgsc2015-06-12 20:18:34 +0800
committerxgdgsc2015-06-12 20:18:34 +0800
commit6e0bb9278fb5e88c90df54d7fa0851f76e25d6d8 (patch)
tree723e5f9482f132eb44f937f6af2120095e3d22f5
downloadaur-6e0bb9278fb5e88c90df54d7fa0851f76e25d6d8.tar.gz
Initial import
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD40
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a47f36c900aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = youdao-qt-git
+ pkgdesc = openyoudao dictionary client qt version
+ pkgver = 20130313
+ pkgrel = 1
+ url = http://openyoudao.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+
+pkgname = youdao-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b44b93ae1f50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+#Maintainer: xgdgsc<xgdgsc@gmail.com>
+pkgname=youdao-qt-git
+pkgver=20130313
+pkgrel=1
+pkgdesc="openyoudao dictionary client qt version"
+arch=('i686' 'x86_64')
+url="http://openyoudao.org/"
+license=('GPL')
+depends=('qt4')
+#source=('https://gitcafe.com/Jactry/LinDict/zipball/master' 'lindict.desktop')
+#md5sums=('eba0f685008243da4e1dfc98be7c8b25' 'e4fd210491586dc040881aea7db0610d')
+
+_gitroot="git://github.com/lvzongting/youdao-qt.git"
+_gitname="youdao-qt"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+}
+
+package(){
+ cd "$srcdir/$_gitname-build"
+ qmake-qt4
+ make
+ install -Dm755 youdao-qt "$pkgdir/usr/bin/youdao-qt"
+} \ No newline at end of file