summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-12-14 20:01:05 +1300
committerGeorge Rawlinson2022-12-14 20:01:05 +1300
commitc0a450649d69c96cb7e11832891a5d771b17e8b2 (patch)
tree60e4048a40c398be033f1f88ef5b3e851f889146
parent0742f750cc75050456dca125a14b18d47e20b5fe (diff)
downloadaur-c0a450649d69c96cb7e11832891a5d771b17e8b2.tar.gz
upgpkg: youki 0.0.4-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7a85fce805a..bd24e56f33e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = youki
pkgdesc = A container runtime written in Rust
- pkgver = 0.0.3
- pkgrel = 2
+ pkgver = 0.0.4
+ pkgrel = 1
url = https://containers.github.io/youki
arch = x86_64
license = Apache
@@ -15,7 +15,7 @@ pkgbase = youki
optdepends = docker: run via docker
optdepends = podman: run via podman
options = !lto
- source = youki::git+https://github.com/containers/youki.git#commit=541bf4a26cc0c3ec397398ed5971f08285a24076
+ source = youki::git+https://github.com/containers/youki.git#commit=174448ae372ad7e9d3a378c387238dc71688ad5a
md5sums = SKIP
pkgname = youki
diff --git a/PKGBUILD b/PKGBUILD
index 2e48c96c785b..6865e77fbd8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=youki
-pkgver=0.0.3
-pkgrel=2
+pkgver=0.0.4
+pkgrel=1
pkgdesc='A container runtime written in Rust'
arch=('x86_64')
url='https://containers.github.io/youki'
@@ -14,7 +14,7 @@ optdepends=(
'podman: run via podman'
)
options=('!lto')
-_commit='541bf4a26cc0c3ec397398ed5971f08285a24076'
+_commit='174448ae372ad7e9d3a378c387238dc71688ad5a'
source=("$pkgname::git+https://github.com/containers/youki.git#commit=$_commit")
md5sums=('SKIP')
@@ -25,7 +25,7 @@ pkgver() {
}
prepare() {
- cd youki/crates
+ cd youki
# create directory for build artifacts
mkdir build
@@ -35,9 +35,9 @@ prepare() {
}
build() {
- cd youki/crates
+ cd youki
- cargo build --frozen --release
+ cargo build --frozen --release --bin youki
# generate shell completions
for shell in bash fish zsh; do
@@ -45,14 +45,14 @@ build() {
done
}
-check() {
- cd youki/crates
-
- cargo test --frozen
-}
+#check() {
+# cd youki
+#
+# cargo test --frozen
+#}
package() {
- cd youki/crates
+ cd youki
install -vDm755 -t "$pkgdir/usr/bin" target/release/youki