summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeil Green2018-06-11 20:50:43 +0100
committerNeil Green2018-06-11 20:50:43 +0100
commita2d62b28b0260a048598e0b186d10082e245379e (patch)
treeca9d693bad3cf070350323163a020a053e5fd7cb
parent9f4d02a5a3fe415db509a2da49e4994c453b9880 (diff)
downloadaur-a2d62b28b0260a048598e0b186d10082e245379e.tar.gz
bump to 2018.04b71
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad9546ec061e..2f7f07a2f02f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yourkit
pkgdesc = Java CPU and memory profiler.
- pkgver = 2017.02b68
- pkgrel = 2
+ pkgver = 2018.04b71
+ pkgrel = 1
url = http://www.yourkit.com
arch = i686
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = yourkit
optdepends = eclipse: A Java IDE that integrates with Yourkit
optdepends = netbeans: A Java IDE that integrates with Yourkit
options = !strip
- source = http://www.yourkit.com/download/YourKit-JavaProfiler-2017.02-b68.zip
- sha256sums = fa042274fd1fdc87d4b0771cb810049684066f1a134bd88ea286a9bbcb635c99
+ source = https://www.yourkit.com/download/YourKit-JavaProfiler-2018.04-b71.zip
+ sha256sums = 2e9759f803e4d7c138c1c7b8b8cf1be8c6c4a88ac8deac87230e0a34a6a6d0d0
pkgname = yourkit
diff --git a/PKGBUILD b/PKGBUILD
index 24a4ec491b69..959947bcb950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer zml <zml@aoeu.xyz>
# Contributor: Julien Nicoulaud <julien.nicoulaud@gmail.com>
pkgname=yourkit
-_version=2017.02
-_build=68
+_version=2018.04
+_build=71
pkgver=${_version}b${_build}
-pkgrel=2
+pkgrel=1
pkgdesc="Java CPU and memory profiler."
arch=(i686 x86_64)
url="http://www.yourkit.com"
@@ -14,14 +14,14 @@ optdepends=('intellij-idea-community-edition: A Java IDE that integrates with Yo
'eclipse: A Java IDE that integrates with Yourkit'
'netbeans: A Java IDE that integrates with Yourkit')
options=(!strip)
-source=(http://www.yourkit.com/download/YourKit-JavaProfiler-${_version}-b${_build}.zip)
-sha256sums=('fa042274fd1fdc87d4b0771cb810049684066f1a134bd88ea286a9bbcb635c99')
+source=(https://www.yourkit.com/download/YourKit-JavaProfiler-${_version}-b${_build}.zip)
+sha256sums=('2e9759f803e4d7c138c1c7b8b8cf1be8c6c4a88ac8deac87230e0a34a6a6d0d0')
build() {
msg2 "Generate scripts for /usr/bin..."
cat <<EOF > "${srcdir}"/${pkgname}.sh
#!/bin/sh
-cd /opt/${pkgname}/bin && sh yjp.sh $@
+cd /opt/${pkgname}/bin && sh profiler.sh $@
EOF
msg2 "Generate desktop application entry for recorder..."
@@ -30,7 +30,7 @@ EOF
Name=Yourkit
Comment=${pkgdesc}
Exec=/usr/bin/${pkgname} %u
-Icon=/opt/${pkgname}/bin/yjp.ico
+Icon=/opt/${pkgname}/bin/profiler.ico
Terminal=false
Type=Application
Categories=Application;Development;
@@ -50,10 +50,6 @@ package() {
ln -s /opt/${pkgname}/probes "${pkgdir}/usr/share/doc/${pkgname}/probes"
ln -s /opt/${pkgname}/samples "${pkgdir}/usr/share/doc/${pkgname}/samples"
- msg2 "Install link to the config file in /etc..."
- install -dm755 "${pkgdir}"/etc
- ln -s /opt/${pkgname}/bin/yjp.ini "${pkgdir}"/etc/${pkgname}.ini
-
msg2 "Install links to copyright resources at /usr/share/licenses/${pkgname}..."
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
ln -s /opt/${pkgname}/license.html "${pkgdir}/usr/share/licenses/${pkgname}/"