summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Görtz2016-02-12 11:10:28 +0100
committerAlexander Görtz2016-02-12 11:10:28 +0100
commiteadefbe6349d7dfbb2f1649323e0e037f5a507ec (patch)
tree97975012c596f40070c04c36b5de4c0f1d310e44
downloadaur-eadefbe6349d7dfbb2f1649323e0e037f5a507ec.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92943117abd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 5.0.0
+# Fri Feb 12 10:07:21 UTC 2016
+pkgbase = yourls-plugin-random-keywords-git
+ pkgdesc = Assign random keywords to shorturls, like bitly.
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://github.com/YOURLS/random-keywords
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = yourls
+ source = yourls-plugin-random-keywords-git::git+https://github.com/YOURLS/random-keywords.git
+ md5sums = SKIP
+
+pkgname = yourls-plugin-random-keywords-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d5741b6da50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander Görtz <aur@nyloc.de>
+
+pkgname=yourls-plugin-random-keywords-git
+pkgver=0.0
+pkgrel=1
+pkgdesc="Assign random keywords to shorturls, like bitly."
+arch=('any')
+url="https://github.com/YOURLS/random-keywords"
+license=('MIT')
+depends=('yourls')
+makedepends=('git')
+source=("${pkgname}"::"git+https://github.com/YOURLS/random-keywords.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -D plugin.php "${pkgdir}/usr/share/webapps/yourls/user/plugins/random-keywords/plugin.php"
+}