summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Scalabrino2018-03-26 18:29:19 +0200
committerSimone Scalabrino2018-03-26 18:29:19 +0200
commitc7d62101d7199b05bff1f977d299ff3e7677650d (patch)
treefd90281612b679482f7199979b52084425a49cfc
downloadaur-c7d62101d7199b05bff1f977d299ff3e7677650d.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--youtube.desktop10
-rw-r--r--youtube.qtws31
-rw-r--r--youtube.svg12
5 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9151841c6ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = youtube-desktop
+ pkgdesc = YouTube web-app based on qtws
+ pkgver = 0.91
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qtws-base
+ source = youtube.qtws
+ source = youtube.svg
+ source = youtube.desktop
+ md5sums = 40f58dab4c9016eb8e188d9d139a9682
+ md5sums = 241537903d64d8a0d6ad6b82c8998a70
+ md5sums = c17fe0b630bb961922e67b1be740a3c7
+
+pkgname = youtube-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53000451b98e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Simone Scalabrino <s dot scalabrino 9 at gmail dot com>
+webappname=youtube
+pkgname=${webappname}-desktop
+pkgver=0.91
+pkgrel=1
+pkgdesc='YouTube web-app based on qtws'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qtws-base')
+source=("$webappname.qtws" "$webappname.svg" "$webappname.desktop")
+md5sums=('40f58dab4c9016eb8e188d9d139a9682'
+ '241537903d64d8a0d6ad6b82c8998a70'
+ 'c17fe0b630bb961922e67b1be740a3c7')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/qtws-apps/$webappname
+ echo ${srcdir}
+
+ install -Dm644 ${srcdir}/$webappname.qtws ${pkgdir}/usr/share/qtws-apps/$webappname/$webappname.qtws
+ install -Dm755 ${srcdir}/$webappname.desktop ${pkgdir}/usr/share/applications/$webappname-desktop.desktop
+ install -Dm644 ${srcdir}/$webappname.svg ${pkgdir}/usr/share/pixmaps/$webappname-desktop.svg
+}
+
diff --git a/youtube.desktop b/youtube.desktop
new file mode 100644
index 000000000000..77dd14d2c8a7
--- /dev/null
+++ b/youtube.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=YouTube
+GenericName=YouTube
+Comment=YouTube Standalone Player
+Categories=Network;AudioVideo;Player;
+Exec=/usr/bin/qtws /usr/share/qtws-apps/youtube/youtube.qtws --disable-seccomp-filter-sandbox --register-pepper-plugins="/usr/lib/qt/plugins/ppapi/libwidevinecdmadapter.so; application/x-ppapi-widevine-cdm"
+Icon=youtube-desktop.svg
+StartupNotify=true
+Terminal=false
+Type=Application
diff --git a/youtube.qtws b/youtube.qtws
new file mode 100644
index 000000000000..e5641a9c8755
--- /dev/null
+++ b/youtube.qtws
@@ -0,0 +1,31 @@
+{
+ "name": "Youtube",
+ "scope": ["youtube.com"],
+ "plugins": [],
+ "home": "http://youtube.com",
+ "icon": "/usr/share/pixmaps/youtube-desktop.svg",
+ "saveSession": false,
+ "multimedia": true,
+ "menu": [
+ {
+ "title": "Trending",
+ "action": "http://youtube.com/feed/trending"
+ },
+ {
+ "title": "Subscriptions",
+ "action": "http://youtube.com/feed/subscriptions"
+ },
+ {
+ "title": "History",
+ "action": "http://youtube.com/feed/history"
+ },
+ {
+ "title": "Playlist",
+ "action": "http://youtube.com/playlist"
+ },
+ {
+ "title": "Settings",
+ "action": "http://youtube.com/account"
+ }
+ ]
+}
diff --git a/youtube.svg b/youtube.svg
new file mode 100644
index 000000000000..b1c627719ff8
--- /dev/null
+++ b/youtube.svg
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 48 48" version="1.1" width="48px" height="48px">
+<g id="surface1">
+<path style=" fill:#455A64;" d="M 14.539063 6 L 16.664063 6 L 18.035156 11.496094 L 18.167969 11.496094 L 19.476563 6.003906 L 21.621094 6.003906 L 19.164063 14.039063 L 19.164063 20 L 17.050781 20 L 17.050781 14.296875 Z "/>
+<path style=" fill:#455A64;" d="M 21.523438 11.921875 C 21.523438 11.140625 21.777344 10.511719 22.285156 10.050781 C 22.789063 9.582031 23.464844 9.347656 24.320313 9.347656 C 25.097656 9.347656 25.730469 9.59375 26.226563 10.085938 C 26.722656 10.574219 26.96875 11.207031 26.96875 11.980469 L 26.96875 17.214844 C 26.96875 18.082031 26.726563 18.761719 26.242188 19.257813 C 25.757813 19.753906 25.089844 20 24.234375 20 C 23.410156 20 22.757813 19.742188 22.261719 19.234375 C 21.769531 18.726563 21.523438 18.039063 21.523438 17.179688 Z M 23.453125 17.367188 C 23.453125 17.644531 23.519531 17.863281 23.660156 18.015625 C 23.792969 18.164063 23.980469 18.238281 24.230469 18.238281 C 24.484375 18.238281 24.683594 18.164063 24.835938 18.007813 C 24.984375 17.855469 25.0625 17.640625 25.0625 17.367188 L 25.0625 11.847656 C 25.0625 11.625 24.980469 11.445313 24.828125 11.308594 C 24.679688 11.175781 24.476563 11.105469 24.230469 11.105469 C 24.003906 11.105469 23.8125 11.175781 23.671875 11.308594 C 23.527344 11.445313 23.453125 11.625 23.453125 11.847656 Z "/>
+<path style=" fill:#455A64;" d="M 33.917969 9.605469 L 33.917969 20 L 32.042969 20 L 32.042969 18.734375 C 31.695313 19.148438 31.339844 19.460938 30.960938 19.675781 C 30.589844 19.890625 30.226563 20 29.875 20 C 29.441406 20 29.117188 19.851563 28.894531 19.546875 C 28.675781 19.246094 28.566406 18.796875 28.566406 18.191406 L 28.566406 9.605469 L 30.441406 9.605469 L 30.441406 17.492188 C 30.441406 17.726563 30.480469 17.902344 30.558594 18.011719 C 30.636719 18.113281 30.765625 18.171875 30.941406 18.171875 C 31.082031 18.171875 31.253906 18.101563 31.460938 17.957031 C 31.675781 17.816406 31.867188 17.632813 32.042969 17.414063 L 32.042969 9.605469 Z "/>
+<path style=" fill:#FFFFFF;" d="M 38.800781 26.4375 C 38.800781 24.097656 36.859375 22.199219 34.46875 22.199219 C 31.058594 22.054688 27.566406 21.996094 24 22 C 20.4375 21.996094 16.945313 22.058594 13.53125 22.199219 C 11.144531 22.199219 9.203125 24.097656 9.203125 26.4375 C 9.0625 28.289063 8.996094 30.144531 9 32 C 8.996094 33.855469 9.058594 35.707031 9.203125 37.5625 C 9.203125 39.90625 11.140625 41.804688 13.53125 41.804688 C 16.945313 41.945313 20.4375 42.003906 24 42 C 27.5625 42.007813 31.058594 41.945313 34.46875 41.804688 C 36.859375 41.804688 38.800781 39.90625 38.800781 37.5625 C 38.941406 35.707031 39.007813 33.855469 39 32 C 39.007813 30.144531 38.941406 28.289063 38.800781 26.4375 Z "/>
+<path style=" fill:#F44336;" d="M 33.851563 30.347656 C 33.632813 30.347656 33.484375 30.402344 33.394531 30.527344 C 33.328125 30.617188 33.246094 30.824219 33.246094 31.277344 L 33.246094 32.050781 L 34.441406 32.050781 L 34.441406 31.277344 C 34.441406 30.832031 34.359375 30.621094 34.289063 30.519531 C 34.203125 30.402344 34.0625 30.347656 33.851563 30.347656 Z "/>
+<path style=" fill:#F44336;" d="M 26.863281 30.386719 C 26.777344 30.429688 26.695313 30.492188 26.605469 30.578125 L 26.605469 36.453125 C 26.71875 36.566406 26.824219 36.644531 26.921875 36.695313 C 27.035156 36.753906 27.148438 36.777344 27.269531 36.777344 C 27.5 36.777344 27.570313 36.6875 27.59375 36.652344 C 27.652344 36.582031 27.714844 36.433594 27.714844 36.113281 L 27.714844 31.109375 C 27.714844 30.832031 27.660156 30.617188 27.5625 30.484375 C 27.429688 30.304688 27.164063 30.234375 26.863281 30.386719 Z "/>
+<path style=" fill:#F44336;" d="M 38.800781 26.4375 C 38.800781 24.097656 36.859375 22.199219 34.46875 22.199219 C 31.058594 22.054688 27.566406 21.996094 24 22 C 20.4375 21.996094 16.945313 22.058594 13.53125 22.199219 C 11.144531 22.199219 9.203125 24.097656 9.203125 26.4375 C 9.0625 28.289063 8.996094 30.144531 9 32 C 8.996094 33.855469 9.058594 35.707031 9.203125 37.5625 C 9.203125 39.90625 11.140625 41.804688 13.53125 41.804688 C 16.945313 41.945313 20.4375 42.003906 24 42 C 27.5625 42.007813 31.058594 41.945313 34.46875 41.804688 C 36.859375 41.804688 38.800781 39.90625 38.800781 37.5625 C 38.941406 35.707031 39.007813 33.855469 39 32 C 39.007813 30.144531 38.941406 28.289063 38.800781 26.4375 Z M 15.699219 38.382813 C 15.699219 38.492188 15.609375 38.585938 15.496094 38.585938 L 13.445313 38.585938 C 13.332031 38.585938 13.238281 38.492188 13.238281 38.382813 L 13.238281 27.351563 L 11.324219 27.351563 C 11.214844 27.351563 11.121094 27.261719 11.121094 27.148438 L 11.121094 25.246094 C 11.121094 25.132813 11.214844 25.039063 11.324219 25.039063 L 17.617188 25.039063 C 17.730469 25.039063 17.824219 25.132813 17.824219 25.246094 L 17.824219 27.148438 C 17.824219 27.261719 17.730469 27.351563 17.617188 27.351563 L 15.699219 27.351563 Z M 22.996094 38.382813 C 22.996094 38.492188 22.902344 38.585938 22.789063 38.585938 L 20.96875 38.585938 C 20.851563 38.585938 20.761719 38.492188 20.761719 38.382813 L 20.761719 37.832031 C 20.519531 38.0625 20.273438 38.25 20.023438 38.390625 C 19.625 38.617188 19.246094 38.726563 18.863281 38.726563 C 18.375 38.726563 18 38.550781 17.746094 38.210938 C 17.507813 37.886719 17.386719 37.40625 17.386719 36.789063 L 17.386719 28.6875 C 17.386719 28.578125 17.476563 28.484375 17.59375 28.484375 L 19.414063 28.484375 C 19.527344 28.484375 19.617188 28.578125 19.617188 28.6875 L 19.617188 36.117188 C 19.617188 36.359375 19.664063 36.460938 19.691406 36.5 C 19.703125 36.515625 19.742188 36.566406 19.894531 36.566406 C 19.949219 36.566406 20.066406 36.542969 20.285156 36.398438 C 20.460938 36.28125 20.617188 36.136719 20.757813 35.972656 L 20.757813 28.6875 C 20.757813 28.578125 20.851563 28.484375 20.964844 28.484375 L 22.785156 28.484375 C 22.898438 28.484375 22.992188 28.578125 22.992188 28.6875 L 22.992188 38.382813 Z M 30 36.371094 C 30 37.109375 29.839844 37.683594 29.527344 38.082031 C 29.199219 38.5 28.730469 38.707031 28.128906 38.707031 C 27.746094 38.707031 27.394531 38.628906 27.082031 38.472656 C 26.917969 38.390625 26.757813 38.28125 26.605469 38.148438 L 26.605469 38.382813 C 26.605469 38.496094 26.511719 38.585938 26.398438 38.585938 L 24.5625 38.585938 C 24.445313 38.585938 24.355469 38.496094 24.355469 38.382813 L 24.355469 25.242188 C 24.355469 25.128906 24.445313 25.039063 24.5625 25.039063 L 26.398438 25.039063 C 26.511719 25.039063 26.605469 25.128906 26.605469 25.242188 L 26.605469 28.960938 C 26.753906 28.824219 26.914063 28.710938 27.078125 28.617188 C 27.386719 28.445313 27.703125 28.359375 28.019531 28.359375 C 28.660156 28.359375 29.160156 28.597656 29.503906 29.066406 C 29.832031 29.515625 29.996094 30.167969 29.996094 31 Z M 36.730469 33.765625 C 36.730469 33.878906 36.636719 33.96875 36.523438 33.96875 L 33.25 33.96875 L 33.25 35.589844 C 33.25 36.183594 33.332031 36.4375 33.398438 36.542969 C 33.449219 36.628906 33.550781 36.742188 33.835938 36.742188 C 34.066406 36.742188 34.222656 36.6875 34.304688 36.578125 C 34.339844 36.519531 34.441406 36.296875 34.441406 35.589844 L 34.441406 34.914063 C 34.441406 34.800781 34.535156 34.710938 34.648438 34.710938 L 36.523438 34.710938 C 36.636719 34.710938 36.726563 34.800781 36.726563 34.914063 L 36.726563 35.644531 C 36.726563 36.6875 36.476563 37.488281 35.988281 38.027344 C 35.5 38.570313 34.761719 38.847656 33.792969 38.847656 C 32.921875 38.847656 32.21875 38.550781 31.714844 37.976563 C 31.214844 37.40625 30.957031 36.621094 30.957031 35.644531 L 30.957031 31.289063 C 30.957031 30.398438 31.234375 29.660156 31.789063 29.09375 C 32.339844 28.527344 33.0625 28.238281 33.933594 28.238281 C 34.820313 28.238281 35.519531 28.507813 36.003906 29.039063 C 36.484375 29.566406 36.726563 30.324219 36.726563 31.292969 L 36.726563 33.765625 Z "/>
+</g>
+</svg>