summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2020-04-21 16:55:56 +0300
committerLartza2020-04-21 16:55:56 +0300
commit8f739979cf63e57aa66ec908626ce5315cb06983 (patch)
tree0614562f90706b8152643925bb05a536a69f12ef
parent513b7dcd12df3730e0b77c879c9e0f54c2d06537 (diff)
downloadaur-8f739979cf63e57aa66ec908626ce5315cb06983.tar.gz
Update URLs
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa2609e8e481..f4f9f1c87479 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = youtube-dl-git
pkgdesc = A small command-line program to download videos from YouTube.com and a few more sites (git version)
- pkgver = 2018.08.04.r3.d37dc6e1c
+ pkgver = 2020.03.24.r16.00eb865b3
pkgrel = 1
- url = https://github.com/rg3/youtube-dl
+ url = http://ytdl-org.github.io/youtube-dl/
arch = any
license = custom
makedepends = git
- makedepends = python-setuptools
makedepends = pandoc
depends = python
depends = python-setuptools
@@ -16,7 +15,7 @@ pkgbase = youtube-dl-git
optdepends = phantomjs: for openload support
provides = youtube-dl
conflicts = youtube-dl
- source = git+https://github.com/rg3/youtube-dl.git
+ source = git+https://github.com/ytdl-org/youtube-dl.git
md5sums = SKIP
pkgname = youtube-dl-git
diff --git a/PKGBUILD b/PKGBUILD
index eec5e7b45b77..a8dfccddaa2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,41 @@
pkgname=youtube-dl-git
_gitname="youtube-dl"
-pkgver=2018.08.04.r3.d37dc6e1c
+pkgver=2020.03.24.r16.00eb865b3
pkgrel=1
pkgdesc="A small command-line program to download videos from YouTube.com and a few more sites (git version)"
arch=('any')
-url="https://github.com/rg3/youtube-dl"
+url="http://ytdl-org.github.io/youtube-dl/"
license=('custom')
depends=('python' 'python-setuptools')
-makedepends=('git' 'python-setuptools' 'pandoc')
+makedepends=('git' 'pandoc')
optdepends=('ffmpeg: for video post-processing'
'rtmpdump: for rtmp streams support'
'atomicparsley: for embedding thumbnails into m4a files'
'phantomjs: for openload support')
provides=("youtube-dl")
conflicts=("youtube-dl")
-source=('git+https://github.com/rg3/youtube-dl.git')
+source=('git+https://github.com/ytdl-org/youtube-dl.git')
md5sums=('SKIP')
pkgver() {
- cd $srcdir/$_gitname
+ cd $_gitname
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
- cd $srcdir/$_gitname
+ cd $_gitname
sed -i 's|etc/bash_completion.d|share/bash-completion/completions|' setup.py
sed -i 's|etc/fish/completions|share/fish/completions|' setup.py
}
build() {
- cd $srcdir/$_gitname
+ cd $_gitname
make pypi-files zsh-completion
}
package() {
- cd $srcdir/$_gitname
+ cd $_gitname
python setup.py install --root="${pkgdir}/" --optimize=1
mv "${pkgdir}/usr/share/bash-completion/completions/youtube-dl.bash-completion" \
"${pkgdir}/usr/share/bash-completion/completions/youtube-dl"