summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsfx2015-12-05 10:08:35 +0100
committersfx2015-12-05 10:08:35 +0100
commitee02c693c2e03e504fc1124dec5d86a0879d9a33 (patch)
tree884f91b4599bbfbf99106b9d91450a044f759ed8
parente6ec25aa93595c305e797b134a706e12bd6a580b (diff)
downloadaur-ee02c693c2e03e504fc1124dec5d86a0879d9a33.tar.gz
Switched to zipball. Thanks everyone.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4f04dbffd5..68d8a0319827 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = youtube-dl-git
pkgdesc = A small command-line program to download videos from YouTube.com and a few more sites - git version
- pkgver = 2015.11.27.1.r38.g22d7368
+ pkgver = 2015.12.05.0bc4ee6
pkgrel = 1
url = http://rg3.github.io/youtube-dl
arch = any
@@ -11,8 +11,8 @@ pkgbase = youtube-dl-git
optdepends = ffmpeg: for video post-processing
provides = youtube-dl
conflicts = youtube-dl
- source = git://github.com/rg3/youtube-dl.git
- md5sums = SKIP
+ source = https://github.com/rg3/youtube-dl/archive/master.zip
+ sha512sums = SKIP
pkgname = youtube-dl-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c40304fcb878
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+master.zip
+src
+pkg
+youtube-dl-git-*
diff --git a/PKGBUILD b/PKGBUILD
index 7427e77f2a06..33907881fc39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,13 @@
-#Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+#Maintainer : flu
+#Contributor : Frederic Bezies <fredbezies at gmail dot com>
#Contributor : baskerville <nihilhill at gmail dot com>
+#Contributor : Smola
-pkgname=youtube-dl-git
-pkgver=2015.11.27.1.r38.g22d7368
+_name=youtube-dl
+_branch=master
+
+pkgname=$_name-git
+pkgver=2015.12.05.0bc4ee6
pkgrel=1
pkgdesc='A small command-line program to download videos from YouTube.com and a few more sites - git version'
@@ -12,29 +17,28 @@ license=('custom')
depends=('python' 'python-setuptools')
makedepends=('git')
-
optdepends=('ffmpeg: for video post-processing')
-provides=('youtube-dl')
-conflicts=('youtube-dl')
-
-source=('git://github.com/rg3/youtube-dl.git')
+provides=("$_name")
+conflicts=("$_name")
-md5sums=('SKIP')
+source=("https://github.com/rg3/$_name/archive/$_branch.zip")
+sha512sums=(SKIP)
-pkgver() {
- cd youtube-dl
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+pkgver() {
+ DATE=$(date +%Y.%m.%d)
+ HASH=$(git ls-remote -h https://github.com/rg3/$_name $_branch | cut -c1-7)
+ echo $DATE.$HASH
}
prepare() {
- cd youtube-dl
+ cd $_name-$_branch
sed -i 's|etc/bash_completion.d|share/bash-completion/completions|' setup.py
sed -i ':etc/fish/completions:d' setup.py
}
package() {
- cd youtube-dl
+ cd $_name-$_branch
python devscripts/bash-completion.py
python setup.py install --root="$pkgdir" --optimize=1