summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2016-04-08 18:33:58 +0300
committerLartza2016-04-08 18:33:58 +0300
commitfc39c87e161fefdffce777a383131e8305f2f729 (patch)
tree0fb7efa1226f67588327456d1b2d3a8991e42f5d
parenta8201ec7a33395084f7b544e07e4e10000836999 (diff)
downloadaur-fc39c87e161fefdffce777a383131e8305f2f729.tar.gz
Rewrote PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD71
2 files changed, 42 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a9bbd04b47c..1918790858f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Apr 8 15:33:38 UTC 2016
pkgbase = youtube-dl-git
- pkgdesc = A small command-line program to download videos from YouTube.com and a few more sites - git version
- pkgver = 2016.03.26.e68d3a0
+ pkgdesc = A small command-line program to download videos from YouTube.com and a few more sites (git version)
+ pkgver = 2016.04.06.r7.a1ff3cd
pkgrel = 1
- url = http://rg3.github.io/youtube-dl
+ url = https://github.com/rg3/youtube-dl
arch = any
license = custom
makedepends = git
+ makedepends = python-setuptools
makedepends = pandoc
depends = python
- depends = python-setuptools
optdepends = ffmpeg: for video post-processing
+ optdepends = rtmpdump: for rtmp streams support
+ optdepends = atomicparsley: for embedding thumbnails into m4a files
provides = youtube-dl
conflicts = youtube-dl
- source = youtube-dl-git-2016.03.26.e68d3a0.zip::https://github.com/rg3/youtube-dl/archive/master.zip
- sha512sums = SKIP
+ source = git+https://github.com/rg3/youtube-dl.git
+ md5sums = SKIP
pkgname = youtube-dl-git
diff --git a/PKGBUILD b/PKGBUILD
index 8fbddc12381f..35ec8ffb9a32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,44 @@
-# Maintainer : flu
-# Contributor : Frederic Bezies <fredbezies at gmail dot com>
-# Contributor : baskerville <nihilhill at gmail dot com>
-# Contributor : Smola
-# Contributor : yan12125
+# Maintainer: Lari Tikkanen <lartza@wippies.com>
-_name=youtube-dl
-_branch=master
-
-pkgname=$_name-git
-pkgver=2016.03.26.e68d3a0
+pkgname=youtube-dl-git
+_gitname="youtube-dl"
+pkgver=2016.04.06.r7.a1ff3cd
pkgrel=1
-
-pkgdesc='A small command-line program to download videos from YouTube.com and a few more sites - git version'
-url="http://rg3.github.io/youtube-dl"
+pkgdesc="A small command-line program to download videos from YouTube.com and a few more sites (git version)"
arch=('any')
+url="https://github.com/rg3/youtube-dl"
license=('custom')
-
-depends=('python' 'python-setuptools')
-makedepends=('git' 'pandoc')
-optdepends=('ffmpeg: for video post-processing')
-
-provides=("$_name")
-conflicts=("$_name")
-
-pkgver() {
- DATE=$(date +%Y.%m.%d)
- HASH=$(git ls-remote -h https://github.com/rg3/$_name $_branch | cut -c1-7)
- echo $DATE.$HASH
+depends=('python')
+makedepends=('git' 'python-setuptools' 'pandoc')
+optdepends=('ffmpeg: for video post-processing'
+ 'rtmpdump: for rtmp streams support'
+ 'atomicparsley: for embedding thumbnails into m4a files')
+provides=("youtube-dl")
+conflicts=("youtube-dl")
+source=('git+https://github.com/rg3/youtube-dl.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_gitname
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-source=("$pkgname-$(pkgver).zip::https://github.com/rg3/$_name/archive/$_branch.zip")
-sha512sums=(SKIP)
-
prepare() {
- cd $_name-$_branch
+ cd $srcdir/$_gitname
sed -i 's|etc/bash_completion.d|share/bash-completion/completions|' setup.py
- sed -i 's|etc/fish/completions|share/fish/vendor_completions.d|' setup.py
+ sed -i 's|etc/fish/completions|share/fish/completions|' setup.py
}
-package() {
- cd $_name-$_branch
-
- make bash-completion zsh-completion fish-completion README.txt youtube-dl.1
- python setup.py install --root="$pkgdir" --optimize=1
+build() {
+ cd $srcdir/$_gitname
+ make pypi-files zsh-completion
+}
- mv "$pkgdir"/usr/share/bash-completion/completions/youtube-dl.bash-completion \
- "$pkgdir"/usr/share/bash-completion/completions/youtube-dl
- install -D -m644 youtube-dl.zsh "$pkgdir"/usr/share/zsh/site-functions/_youtube-dl
- install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+package() {
+ cd $srcdir/$_gitname
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ mv "${pkgdir}/usr/share/bash-completion/completions/youtube-dl.bash-completion" \
+ "${pkgdir}/usr/share/bash-completion/completions/youtube-dl"
+ install -Dm644 youtube-dl.zsh "${pkgdir}/usr/share/zsh/site-functions/_youtube-dl"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}