summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 17:21:17 +0200
committerwillemw122015-06-08 17:21:17 +0200
commitc68a3d41eab7e49c0042a272bd8b8da17e550127 (patch)
treece099e909ad9ba6751b5db2f947fdf300094bb08
downloadaur-c68a3d41eab7e49c0042a272bd8b8da17e550127.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
-rw-r--r--UNLICENSE24
-rw-r--r--youtube-dl-gui-git.install12
-rw-r--r--youtube-dl-gui.desktop8
5 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb1dc61b308e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = youtube-dl-gui-git
+ pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython
+ pkgver = r255.d335cb4
+ pkgrel = 1
+ url = https://github.com/MrS0m30n3/youtube-dl-gui
+ install = youtube-dl-gui-git.install
+ arch = any
+ license = custom:UNLICENSE
+ makedepends = git
+ depends = gtk-update-icon-cache
+ depends = python2
+ depends = wxpython
+ optdepends = ffmpeg: convert video files to audio-only files
+ optdepends = youtube-dl: alternative to the youtube-dl program file downloaded by youtube-dl-gui
+ provides = youtube-dl-gui
+ conflicts = youtube-dl-gui
+ source = git://github.com/MrS0m30n3/youtube-dl-gui.git
+ source = youtube-dl-gui.desktop
+ source = UNLICENSE
+ md5sums = SKIP
+ md5sums = 55914f7c32fafa895d7bf447efc9c18e
+ md5sums = 7246f848faa4e9c9fc0ea91122d6e680
+
+pkgname = youtube-dl-gui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8938c68f24cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=youtube-dl-gui
+pkgname=$_pkgname-git
+pkgver=r255.d335cb4
+pkgrel=1
+pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython"
+arch=('any')
+url="https://github.com/MrS0m30n3/youtube-dl-gui"
+license=('custom:UNLICENSE')
+depends=('gtk-update-icon-cache' 'python2' 'wxpython')
+optdepends=('ffmpeg: convert video files to audio-only files'
+ 'youtube-dl: alternative to the youtube-dl program file downloaded by youtube-dl-gui')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+install=$pkgname.install
+source=(git://github.com/MrS0m30n3/$_pkgname.git
+ youtube-dl-gui.desktop
+ UNLICENSE)
+# http://unlicense.org/UNLICENSE)
+md5sums=('SKIP'
+ '55914f7c32fafa895d7bf447efc9c18e'
+ '7246f848faa4e9c9fc0ea91122d6e680')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ sed -i 's|usr/local/share|usr/share|' setup.py
+ sed -i 's|#![ ]*/usr/bin/env python[ ]*$|#!/usr/bin/env python2|' setup.py youtube_dl_gui/*.py
+}
+
+package() {
+ install -Dm644 youtube-dl-gui.desktop "$pkgdir/usr/share/applications/youtube-dl-gui.desktop"
+ install -Dm644 UNLICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd $_pkgname
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm755 youtube_dl_gui/__main__.py "$pkgdir/usr/bin/youtube-dl-gui"
+}
+
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>
diff --git a/youtube-dl-gui-git.install b/youtube-dl-gui-git.install
new file mode 100644
index 000000000000..5f3cb0109232
--- /dev/null
+++ b/youtube-dl-gui-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
diff --git a/youtube-dl-gui.desktop b/youtube-dl-gui.desktop
new file mode 100644
index 000000000000..d7ad2deafbd9
--- /dev/null
+++ b/youtube-dl-gui.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Youtube-dl GUI
+Exec=youtube-dl-gui
+Icon=youtube-dl-gui_48x48
+Categories=Network;
+Comment=GUI for youtube-dl downloader