summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-05-23 09:24:19 -0600
committerMark Wagie2021-05-23 09:24:19 -0600
commit7d34cb12abd5957b5fbbb94303f0c0332b34e7db (patch)
tree2bb634a9a513a608735c98a691e72c9921557ae2
parent80cfbc2ab4d48cbf44a68b2f15748d103d9486a3 (diff)
downloadaur-7d34cb12abd5957b5fbbb94303f0c0332b34e7db.tar.gz
fix symlink, PKGBUILD improvements
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD63
3 files changed, 37 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f8ab2c9af33..2b629f82c7be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,21 @@
pkgbase = youtube-music-bin
- pkgdesc = YouTube Music Desktop App - including custom plugins like built-in ad blocker & downloader
+ pkgdesc = YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)
pkgver = 1.12.0
- pkgrel = 2
- url = https://github.com/th-ch/youtube-music
- arch = i686
+ pkgrel = 3
+ url = https://th-ch.github.io/youtube-music
arch = x86_64
license = MIT
- depends = at-spi2-core
- depends = desktop-file-utils
depends = gtk3
- depends = hicolor-icon-theme
- depends = libappindicator-gtk3
- depends = libnotify
depends = libsecret
- depends = libxss
- depends = libxtst
depends = nss
- depends = util-linux-libs
- depends = xdg-utils
- options = !strip
- options = !emptydirs
- source_x86_64 = https://github.com/th-ch/youtube-music/releases/download/v1.12.0/youtube-music_1.12.0_amd64.deb
- source_x86_64 = https://raw.githubusercontent.com/th-ch/youtube-music/master/license
- sha512sums_x86_64 = e6bc190b67ad2ab2f21939d9b3b6eaf60c4b29a103e797b3456ce4fcd9da71ae262f0a634bf8c64bd467d53cae346956a98d8a4fdf1e0de9498a18cc244982b8
- sha512sums_x86_64 = SKIP
+ optdepends = libnotify: desktop notifications
+ optdepends = libappindicator-gtk3: tray icon
+ provides = youtube-music
+ conflicts = youtube-music
+ source = https://github.com/th-ch/youtube-music/releases/download/v1.12.0/youtube-music_1.12.0_amd64.deb
+ source = https://github.com/th-ch/youtube-music/raw/v1.12.0/license
+ sha256sums = 5edb1bc9a46082e83ad647baae1afe3f8b31c0faf535248ac26a025e799ce84c
+ sha256sums = e7e14b3b771ecadb23f6ee0b6f99d1553e385e35cdb44fc8e36ee7c878dacd08
pkgname = youtube-music-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index f477a568022b..5e409a0b3f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,27 @@
-# Maintainer: Harsh Barsaiyan <hbarsaiyan at gmail dot com>
-# This file is automatically generated. Do not edit.
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Harsh Barsaiyan <hbarsaiyan at gmail dot com>
pkgname=youtube-music-bin
-_pkgname=youtube-music
pkgver=1.12.0
-pkgrel=2
-pkgdesc="YouTube Music Desktop App - including custom plugins like built-in ad blocker & downloader"
-arch=('i686' 'x86_64')
-url="https://github.com/th-ch/youtube-music"
+pkgrel=3
+pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
+arch=('x86_64')
+url="https://th-ch.github.io/youtube-music"
license=('MIT')
-depends=('at-spi2-core' 'desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxtst' 'nss' 'util-linux-libs' 'xdg-utils')
-options=('!strip' '!emptydirs')
-source_x86_64=("https://github.com/th-ch/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb"
- "https://raw.githubusercontent.com/th-ch/youtube-music/master/license")
-sha512sums_x86_64=('e6bc190b67ad2ab2f21939d9b3b6eaf60c4b29a103e797b3456ce4fcd9da71ae262f0a634bf8c64bd467d53cae346956a98d8a4fdf1e0de9498a18cc244982b8'
- 'SKIP')
+depends=('gtk3' 'libsecret' 'nss')
+optdepends=('libnotify: desktop notifications'
+ 'libappindicator-gtk3: tray icon')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("https://github.com/th-ch/youtube-music/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "https://github.com/th-ch/youtube-music/raw/v$pkgver/license")
+sha256sums=('5edb1bc9a46082e83ad647baae1afe3f8b31c0faf535248ac26a025e799ce84c'
+ 'e7e14b3b771ecadb23f6ee0b6f99d1553e385e35cdb44fc8e36ee7c878dacd08')
package(){
+ bsdtar xfv data.tar.xz -C "$pkgdir"
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
-
- install -D -m644 license "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
-}
-
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
- # Link to the binary
- ln -sf '/opt/YouTube Music/youtube-music' '/usr/bin/youtube-music'
-
- # SUID chrome-sandbox for Electron 5+
- chmod 4755 '/opt/YouTube Music/chrome-sandbox' || true
-
- update-mime-database /usr/share/mime || true
- update-desktop-database /usr/share/applications || true
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/YouTube Music/${pkgname%-bin}" "$pkgdir/usr/bin/${pkgname%-bin}"
- # Delete the link to the binary
- rm -f '/usr/bin/youtube-music'
- update-desktop-database -q
+ install -Dm644 license -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
}