summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarsh Barsaiyan2021-05-06 18:05:17 +0530
committerHarsh Barsaiyan2021-05-06 18:05:17 +0530
commit80cfbc2ab4d48cbf44a68b2f15748d103d9486a3 (patch)
tree9431ca3d359b21686c8cd0d0acc24626f8c0245f
parentbfeb6b078d03a77b0c85b0cf6771d1b4a6d3299c (diff)
downloadaur-80cfbc2ab4d48cbf44a68b2f15748d103d9486a3.tar.gz
Switch to .deb package
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD70
-rw-r--r--youtube-music-bin.desktop11
3 files changed, 60 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d78587f21cb6..7f8ab2c9af33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,29 @@
pkgbase = youtube-music-bin
- pkgdesc = YouTube Music Desktop App bundled with custom plugins like built-in ad blocker & downloader
+ pkgdesc = YouTube Music Desktop App - including custom plugins like built-in ad blocker & downloader
pkgver = 1.12.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/th-ch/youtube-music
+ arch = i686
arch = x86_64
license = MIT
- makedepends = git
- noextract = ${_pkgname}-${pkgver}.AppImage
+ depends = at-spi2-core
+ depends = desktop-file-utils
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = libsecret
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = util-linux-libs
+ depends = xdg-utils
options = !strip
- source = https://github.com/th-ch/youtube-music/releases/download/v1.12.0/YouTube-Music-1.12.0.AppImage
- source = https://raw.githubusercontent.com/th-ch/youtube-music/master/license
- source = youtube-music-bin.desktop
- sha512sums = 1a2f0cee51490127020288e45806a6152364727cf5e7f99b3d82e63342b4859a37eac1ccdd0ce4d0cdd1836f117021510d061dbd6d64822f8f163ad2f1ce7308
- sha512sums = SKIP
- sha512sums = 5cde2a00f56761b510a550cbf685206646519068f5b1b14d0a0e6c954e38f677aef8ec83c53ff2c85b67ae539a4a419368f2593207548a868466502e675ae38c
+ options = !emptydirs
+ source_x86_64 = https://github.com/th-ch/youtube-music/releases/download/v1.12.0/youtube-music_1.12.0_amd64.deb
+ source_x86_64 = https://raw.githubusercontent.com/th-ch/youtube-music/master/license
+ sha512sums_x86_64 = e6bc190b67ad2ab2f21939d9b3b6eaf60c4b29a103e797b3456ce4fcd9da71ae262f0a634bf8c64bd467d53cae346956a98d8a4fdf1e0de9498a18cc244982b8
+ sha512sums_x86_64 = SKIP
pkgname = youtube-music-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8e85ecab6695..f477a568022b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,52 @@
-# Maintainer: Harsh Barsaiyan <hbarsaiyan@gmail.com>
+# Maintainer: Harsh Barsaiyan <hbarsaiyan at gmail dot com>
# This file is automatically generated. Do not edit.
pkgname=youtube-music-bin
-_pkgname=YouTube-Music
+_pkgname=youtube-music
pkgver=1.12.0
-pkgrel=1
-epoch=
-pkgdesc="YouTube Music Desktop App bundled with custom plugins like built-in ad blocker & downloader"
-arch=('x86_64')
+pkgrel=2
+pkgdesc="YouTube Music Desktop App - including custom plugins like built-in ad blocker & downloader"
+arch=('i686' 'x86_64')
url="https://github.com/th-ch/youtube-music"
license=('MIT')
-makedepends=('git')
-source=("https://github.com/th-ch/youtube-music/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
- "https://raw.githubusercontent.com/th-ch/youtube-music/master/license"
- "youtube-music-bin.desktop")
-noextract=('${_pkgname}-${pkgver}.AppImage')
-options=(!strip)
-sha512sums=(
- "1a2f0cee51490127020288e45806a6152364727cf5e7f99b3d82e63342b4859a37eac1ccdd0ce4d0cdd1836f117021510d061dbd6d64822f8f163ad2f1ce7308"
- "SKIP"
- "5cde2a00f56761b510a550cbf685206646519068f5b1b14d0a0e6c954e38f677aef8ec83c53ff2c85b67ae539a4a419368f2593207548a868466502e675ae38c"
-)
-
-prepare(){
- chmod +x $_pkgname-$pkgver.AppImage
- ./$_pkgname-$pkgver.AppImage --appimage-extract
+depends=('at-spi2-core' 'desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxtst' 'nss' 'util-linux-libs' 'xdg-utils')
+options=('!strip' '!emptydirs')
+source_x86_64=("https://github.com/th-ch/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb"
+ "https://raw.githubusercontent.com/th-ch/youtube-music/master/license")
+sha512sums_x86_64=('e6bc190b67ad2ab2f21939d9b3b6eaf60c4b29a103e797b3456ce4fcd9da71ae262f0a634bf8c64bd467d53cae346956a98d8a4fdf1e0de9498a18cc244982b8'
+ 'SKIP')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 license "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
}
-package() {
- # install license
- install -Dm644 license "${pkgdir}/usr/share/licenses/${pkgname}/license"
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/YouTube Music/youtube-music' '/usr/bin/youtube-music'
- # install icon
- install -Dm644 "${srcdir}/squashfs-root/youtube-music.png" "${pkgdir}/usr/share/pixmaps/youtube-music-bin.png"
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/YouTube Music/chrome-sandbox' || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
- # install appimage
- install -Dm755 ${_pkgname}-${pkgver}.AppImage "${pkgdir}/usr/bin/youtube-music-bin"
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- # install desktop entry
- install -Dm755 youtube-music-bin.desktop "${pkgdir}/usr/share/applications/youtube-music-bin.desktop"
+ # Delete the link to the binary
+ rm -f '/usr/bin/youtube-music'
+ update-desktop-database -q
}
diff --git a/youtube-music-bin.desktop b/youtube-music-bin.desktop
deleted file mode 100644
index 0ec266c4986a..000000000000
--- a/youtube-music-bin.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=YouTube Music
-Comment=YouTube Music Desktop App - including custom plugins
-GenericName=YouTube Music
-Exec=youtube-music-bin %U
-Icon=/usr/share/pixmaps/youtube-music-bin.png
-Terminal=false
-Type=Application
-StartupNotify=true
-StartupWMClass=YouTube Music
-Categories=AudioVideo;Player;Audio;Youtube;Music