summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaurabh Sharma2019-07-13 05:45:59 +0530
committerSaurabh Sharma2019-07-13 05:45:59 +0530
commitd0ea12295e1b15f595473d7229932a7a04ee9bff (patch)
tree99f4e4c417d6c5c90a058c56334de4f700fe7c6f
downloadaur-d0ea12295e1b15f595473d7229932a7a04ee9bff.tar.gz
Added the necessary files
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--youtube-music.desktop10
-rw-r--r--youtube-music.pngbin0 -> 16404 bytes
-rw-r--r--youtube-music.qtws23
5 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13895cd52b75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = youtube-music-desktop
+ pkgdesc = YouTube Music web-app based on qtws
+ pkgver = 1.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qtws-base
+ source = youtube-music.qtws
+ source = youtube-music.png
+ source = youtube-music.desktop
+ md5sums = a631b8125712a7ccd1b57e03c1d45b91
+ md5sums = 54dcc4edaf29caa9524c89b7de8862d7
+ md5sums = a7b093cc7607caef95dd78016a9930af
+
+pkgname = youtube-music-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5418ea06165d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Saurabh Kumar Sharma <saurabh000345@gmail.com>
+webappname=youtube-music
+pkgname=${webappname}-desktop
+pkgver=1.0
+pkgrel=1
+pkgdesc='YouTube Music web-app based on qtws'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qtws-base')
+source=("$webappname.qtws" "$webappname.png" "$webappname.desktop")
+md5sums=('a631b8125712a7ccd1b57e03c1d45b91'
+ '54dcc4edaf29caa9524c89b7de8862d7'
+ 'a7b093cc7607caef95dd78016a9930af')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/qtws-apps/$webappname
+ echo ${srcdir}
+
+ install -Dm644 ${srcdir}/$webappname.qtws ${pkgdir}/usr/share/qtws-apps/$webappname/$webappname.qtws
+ install -Dm755 ${srcdir}/$webappname.desktop ${pkgdir}/usr/share/applications/$webappname-desktop.desktop
+ install -Dm644 ${srcdir}/$webappname.png ${pkgdir}/usr/share/pixmaps/$webappname-desktop.png
+}
diff --git a/youtube-music.desktop b/youtube-music.desktop
new file mode 100644
index 000000000000..23e81f7fb13d
--- /dev/null
+++ b/youtube-music.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=YouTube Music
+GenericName=YouTube Music
+Comment=YouTube Music Standalone Player
+Categories=Network;AudioVideo;Player;
+Exec=/usr/bin/qtws /usr/share/qtws-apps/youtube-music/youtube-music.qtws --disable-seccomp-filter-sandbox --register-pepper-plugins="/usr/lib/qt/plugins/ppapi/libwidevinecdmadapter.so; application/x-ppapi-widevine-cdm"
+Icon=/usr/share/pixmaps/youtube-music.png
+StartupNotify=true
+Terminal=false
+Type=Application
diff --git a/youtube-music.png b/youtube-music.png
new file mode 100644
index 000000000000..492a0271973e
--- /dev/null
+++ b/youtube-music.png
Binary files differ
diff --git a/youtube-music.qtws b/youtube-music.qtws
new file mode 100644
index 000000000000..05d809e3f93f
--- /dev/null
+++ b/youtube-music.qtws
@@ -0,0 +1,23 @@
+{
+ "name": "Youtube Music",
+ "scope": ["music.youtube.com"],
+ "plugins": [],
+ "home": "http://music.youtube.com",
+ "icon": "/usr/share/pixmaps/youtube-music-desktop.png",
+ "saveSession": true,
+ "multimedia": true,
+ "menu": [
+ {
+ "title": "Home",
+ "action": "http://music.youtube.com"
+ },
+ {
+ "title": "Hotlist",
+ "action": "http://music.youtube.com/hotlist"
+ },
+ {
+ "title": "Library",
+ "action": "http://music.youtube.com/library/playlists"
+ }
+ ]
+}