summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-02-10 08:11:55 -0700
committerMark Wagie2023-02-10 08:11:55 -0700
commit3ec03803a6c9a4ec73c21d311519b5641ef80329 (patch)
tree9724196389a1abece301424c2fdd4233c17693b8
parentd57c2256487efca333263870b8bca175655654d6 (diff)
downloadaur-3ec03803a6c9a4ec73c21d311519b5641ef80329.tar.gz
bump Electron & minimum Node.js versions, fix Yarn cache folder command
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--youtube-music.sh2
3 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06fc212bdcb8..01e39a0fad28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,24 @@
pkgbase = youtube-music-git
pkgdesc = YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)
- pkgver = 1.19.0.r1.gfcb92fd
+ pkgver = 1.19.0.r74.g7bdbab5
pkgrel = 1
url = https://th-ch.github.io/youtube-music
arch = x86_64
license = MIT
makedepends = git
- makedepends = nodejs>=14.0.0
+ makedepends = nodejs>=16.0.0
makedepends = npm
makedepends = yarn
- depends = electron20
+ depends = electron22
depends = libsecret
optdepends = libnotify: desktop notifications
- optdepends = libappindicator-gtk3: tray icon
provides = youtube-music
conflicts = youtube-music
source = git+https://github.com/th-ch/youtube-music.git
source = youtube-music.sh
source = youtube-music.desktop
sha256sums = SKIP
- sha256sums = 5aed4ca6a0326f902b5c34437e46c09b95ea076ae2c98134bdd85cfdf11f675b
+ sha256sums = 66acb7f000ec69c5b22b3bb7f49f020820595ae8ccaa688d28de35924c1c241f
sha256sums = 07af59376e13e5dae2e7e38fa09d734a5147d5c344b3aed84c2f3afe22b8af79
pkgname = youtube-music-git
diff --git a/PKGBUILD b/PKGBUILD
index 36c21329425c..048055e87ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=youtube-music-git
-pkgver=1.19.0.r1.gfcb92fd
+pkgver=1.19.0.r74.g7bdbab5
pkgrel=1
-_electronversion=20
+_electronversion=22
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
license=('MIT')
depends=("electron${_electronversion}" 'libsecret')
-makedepends=('git' 'nodejs>=14.0.0' 'npm' 'yarn')
-optdepends=('libnotify: desktop notifications'
- 'libappindicator-gtk3: tray icon')
+makedepends=('git' 'nodejs>=16.0.0' 'npm' 'yarn')
+optdepends=('libnotify: desktop notifications')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/th-ch/youtube-music.git'
"${pkgname%-git}.sh"
"${pkgname%-git}.desktop")
sha256sums=('SKIP'
- '5aed4ca6a0326f902b5c34437e46c09b95ea076ae2c98134bdd85cfdf11f675b'
+ '66acb7f000ec69c5b22b3bb7f49f020820595ae8ccaa688d28de35924c1c241f'
'07af59376e13e5dae2e7e38fa09d734a5147d5c344b3aed84c2f3afe22b8af79')
pkgver() {
@@ -29,7 +28,7 @@ build() {
cd "$srcdir/${pkgname%-git}"
electronDist="/usr/lib/electron${_electronversion}"
electronVer="$(sed s/^v// /usr/lib/electron${_electronversion}/version)"
- yarn config set cache-folder "$srcdir/yarn-cache"
+ yarn config set cacheFolder "$srcdir/yarn-cache"
yarn install
yarn run clean
HOME="$srcdir/.electron-gyp" ./node_modules/.bin/electron-builder --linux dir \
diff --git a/youtube-music.sh b/youtube-music.sh
index 40c94c656abb..905c1c992782 100644
--- a/youtube-music.sh
+++ b/youtube-music.sh
@@ -1,4 +1,4 @@
#!/bin/bash
export ELECTRON_IS_DEV=0
-exec electron20 /usr/lib/youtube-music/app.asar "$@"
+exec electron22 /usr/lib/youtube-music/app.asar "$@"