summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-09-27 09:39:21 -0600
committerMark Wagie2022-09-27 09:39:21 -0600
commit7c39e96ea73ec1bab915d65a18970ba092c182f3 (patch)
treefbc93ad2ba9e3f86df2d2e2697e5834d90614a7c
parent22906096d0c7feed273bfb12a1071b1f4b959b45 (diff)
downloadaur-7c39e96ea73ec1bab915d65a18970ba092c182f3.tar.gz
use Electron 19
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--youtube-music.sh2
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aef9eea7590..55a9465a0ca3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = youtube-music-git
pkgdesc = YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)
- pkgver = 1.17.0.r0.g96b2aab
+ pkgver = 1.18.0.r0.gb843825
pkgrel = 1
url = https://th-ch.github.io/youtube-music
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = youtube-music-git
makedepends = nodejs>=14.0.0
makedepends = npm
makedepends = yarn
- depends = electron
+ depends = electron19
depends = libsecret
optdepends = libnotify: desktop notifications
optdepends = libappindicator-gtk3: tray icon
@@ -19,7 +19,7 @@ pkgbase = youtube-music-git
source = youtube-music.sh
source = youtube-music.desktop
sha256sums = SKIP
- sha256sums = a1d30cedc17ede48b7d627a3797a0918b7bd3c9062e9ed83d61f153c001c1ef8
+ sha256sums = e432833908cfad2b521dd0eb531e650ec816887635622e61b56ef0de94d663cd
sha256sums = 07af59376e13e5dae2e7e38fa09d734a5147d5c344b3aed84c2f3afe22b8af79
pkgname = youtube-music-git
diff --git a/PKGBUILD b/PKGBUILD
index a050f479b745..0a2fa57e76e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=youtube-music-git
-pkgver=1.17.0.r0.g96b2aab
+pkgver=1.18.0.r0.gb843825
pkgrel=1
+_electronversion=19
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
license=('MIT')
-depends=('electron' 'libsecret')
+depends=("electron${_electronversion}" 'libsecret')
makedepends=('git' 'nodejs>=14.0.0' 'npm' 'yarn')
optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
@@ -16,7 +17,7 @@ source=('git+https://github.com/th-ch/youtube-music.git'
"${pkgname%-git}.sh"
"${pkgname%-git}.desktop")
sha256sums=('SKIP'
- 'a1d30cedc17ede48b7d627a3797a0918b7bd3c9062e9ed83d61f153c001c1ef8'
+ 'e432833908cfad2b521dd0eb531e650ec816887635622e61b56ef0de94d663cd'
'07af59376e13e5dae2e7e38fa09d734a5147d5c344b3aed84c2f3afe22b8af79')
pkgver() {
@@ -26,8 +27,8 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- electronDist=/usr/lib/electron
- electronVer=$(sed s/^v// /usr/lib/electron/version)
+ electronDist="/usr/lib/electron${_electronversion}"
+ electronVer="$(sed s/^v// /usr/lib/electron${_electronversion}/version)"
yarn config set cache-folder "$srcdir/yarn-cache"
yarn install
yarn run clean
diff --git a/youtube-music.sh b/youtube-music.sh
index b67b77e3adfb..874a5652b540 100644
--- a/youtube-music.sh
+++ b/youtube-music.sh
@@ -1,4 +1,4 @@
#!/bin/bash
export ELECTRON_IS_DEV=0
-exec electron /usr/lib/youtube-music/app.asar "$@"
+exec electron19 /usr/lib/youtube-music/app.asar "$@"