summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-03 08:35:48 -0600
committerMark Wagie2022-04-03 08:35:48 -0600
commitd07f745f1f3dd0a1390e181f4bdf41425107a244 (patch)
tree09a26c0948840ba1f3cf6267102d4752c79f6dd8
parentc570e9d10f55057079e996f2d94e3df5682823bb (diff)
downloadaur-d07f745f1f3dd0a1390e181f4bdf41425107a244.tar.gz
use current Node.js, don't call NPX
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD40
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57069651a3d3..cf67adfcff7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = youtube-music-git
pkgdesc = YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)
- pkgver = 1.14.0.r0.gf40ed04
- pkgrel = 1
+ pkgver = 1.16.0.r3.g5cffb6f
+ pkgrel = 2
url = https://th-ch.github.io/youtube-music
arch = x86_64
license = MIT
makedepends = git
- makedepends = nvm
+ makedepends = npm
makedepends = yarn
depends = electron
depends = libsecret
diff --git a/PKGBUILD b/PKGBUILD
index 3d8609508a72..7f79d599e8fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=youtube-music-git
-pkgver=1.14.0.r0.gf40ed04
-pkgrel=1
-_nodeversion=14
+pkgver=1.16.0.r3.g5cffb6f
+pkgrel=2
+#_nodeversion=14
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
license=('MIT')
depends=('electron' 'libsecret')
-makedepends=('git' 'nvm' 'yarn')
+makedepends=('git' 'npm' 'yarn')
optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
provides=("${pkgname%-git}")
@@ -25,32 +25,32 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-_ensure_local_nvm() {
- # let's be sure we are starting clean
- which nvm >/dev/null 2>&1 && nvm deactivate && nvm unload
- export NVM_DIR="$srcdir/.nvm"
+#_ensure_local_nvm() {
+# # let's be sure we are starting clean
+# which nvm >/dev/null 2>&1 && nvm deactivate && nvm unload
+# export NVM_DIR="$srcdir/.nvm"
- # The init script returns 3 if version specified
- # in ./.nvrc is not (yet) installed in $NVM_DIR
- # but nvm itself still gets loaded ok
- source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
-}
+# # The init script returns 3 if version specified
+# # in ./.nvrc is not (yet) installed in $NVM_DIR
+# # but nvm itself still gets loaded ok
+# source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
+#}
-prepare() {
-# Use Node.js 14
- _ensure_local_nvm
- nvm install "$_nodeversion"
-}
+#prepare() {
+## Use Node.js 14
+# _ensure_local_nvm
+# nvm install "$_nodeversion"
+#}
build() {
cd "$srcdir/${pkgname%-git}"
electronDist=/usr/lib/electron
electronVer=$(sed s/^v// /usr/lib/electron/version)
- _ensure_local_nvm
+# _ensure_local_nvm
yarn config set cache-folder "$srcdir/yarn-cache"
yarn install
yarn run clean
- npx electron-builder --linux dir \
+ ./node_modules/.bin/electron-builder --linux dir \
$dist -c.electronDist=$electronDist -c.electronVersion=$electronVer
}