summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-06 13:19:22 -0600
committerMark Wagie2023-10-06 13:19:22 -0600
commite4eb3be3ba734e90be28fc16dabf62ced49e8052 (patch)
treebaaa18f199bfcdde1cd020ef7978ca5dfeb7b852
parent711136b4950f945c1ce7466ea1e050749109d8ed (diff)
downloadaur-e4eb3be3ba734e90be28fc16dabf62ced49e8052.tar.gz
adapt to upstream changes
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 967a6dbb3715..18e03f3b673a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = youtube-music-git
pkgdesc = YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)
- pkgver = 1.20.0.r3.g1ed43e1
- pkgrel = 5
+ pkgver = 1.20.0.r101.g375fb08
+ pkgrel = 1
url = https://th-ch.github.io/youtube-music
install = youtube-music.install
arch = x86_64
@@ -9,8 +9,7 @@ pkgbase = youtube-music-git
makedepends = git
makedepends = nodejs>=16.0.0
makedepends = npm
- makedepends = yarn
- depends = electron22
+ depends = electron27
depends = libsecret
optdepends = libnotify: desktop notifications
provides = youtube-music
diff --git a/PKGBUILD b/PKGBUILD
index 2240bd485db5..ae3b32e647f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=youtube-music-git
-pkgver=1.20.0.r3.g1ed43e1
-pkgrel=5
-_electronversion=22
+pkgver=1.20.0.r101.g375fb08
+pkgrel=1
+_electronversion=27
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
license=('MIT')
depends=("electron${_electronversion}" 'libsecret')
-makedepends=('git' 'nodejs>=16.0.0' 'npm' 'yarn')
+makedepends=('git' 'nodejs>=16.0.0' 'npm')
optdepends=('libnotify: desktop notifications')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -29,16 +29,17 @@ build() {
cd "$srcdir/${pkgname%-git}"
electronDist="/usr/lib/electron${_electronversion}"
electronVer="$(sed s/^v// /usr/lib/electron${_electronversion}/version)"
- export YARN_CACHE_FOLDER="$srcdir/yarn-cache"
- yarn install
- yarn run clean
+ export npm_config_cache="$srcdir/npm_cache"
+ npm install
+ npm run clean
+ npm run tsc-and-copy
HOME="$srcdir/.electron-gyp" ./node_modules/.bin/electron-builder --linux dir \
$dist -c.electronDist=$electronDist -c.electronVersion=$electronVer
}
package() {
cd "$srcdir/${pkgname%-git}"
- install -Dm644 dist/linux-unpacked/resources/app.asar -t "$pkgdir/usr/lib/${pkgname%-git}"
+ install -Dm644 pack/linux-unpacked/resources/app.asar -t "$pkgdir/usr/lib/${pkgname%-git}"
install -Dm755 "$srcdir/${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t "$pkgdir/usr/share/applications"
install -Dm644 license -t "$pkgdir/usr/share/licenses/${pkgname%-git}"