summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2017-08-26 08:06:11 -0400
committerredfish2017-08-26 08:06:11 -0400
commitc82c4ef3c3d5431565d509eebed0df7747c35ebe (patch)
treeecc58b6c741a189c0be857293df973eda7e03905
downloadaur-c82c4ef3c3d5431565d509eebed0df7747c35ebe.tar.gz
pkgbuild
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba3f7e89cbd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Aug 26 12:04:52 UTC 2017
+pkgbase = youtube-sync-git
+ pkgdesc = Script for maintaining an up-to-date offline mirror of a YouTube channel.
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/PotcFdk/youtube-sync
+ arch = any
+ license = custom
+ depends = youtube-dl
+ provides = youtube-sync
+ source = git+https://github.com/PotcFdk/youtube-sync.git
+ sha256sums = SKIP
+
+pkgname = youtube-sync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7153a8ae6cb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=youtube-sync-git
+pkgver=0
+pkgrel=1
+pkgdesc="Script for maintaining an up-to-date offline mirror of a YouTube channel."
+arch=('any')
+url="https://github.com/PotcFdk/youtube-sync"
+license=('custom')
+depends=('youtube-dl')
+provides=('youtube-sync')
+source=(git+https://github.com/PotcFdk/youtube-sync.git)
+sha256sums=('SKIP')
+
+_pkgdir=youtube-sync
+
+pkgver() {
+ cd $_pkgdir
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 $_pkgdir/youtube-sync "${pkgdir}/usr/bin/youtube-sync"
+ install -Dm644 $_pkgdir/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}