summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedl1k2023-12-02 15:35:50 +0100
committerknedl1k2023-12-02 15:35:50 +0100
commit477bd8db4c346e138c5461d33149c7e59ca96b94 (patch)
tree09eb75bd5aab6bc87909079f85e8d2b0c6a8b228
parentcb415f9de14342bd2b651cb9d2d6c3a48ab3fa75 (diff)
downloadaur-477bd8db4c346e138c5461d33149c7e59ca96b94.tar.gz
bump version 0.8.0, add missing dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6add2af2165c..1e4f82d362d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = youtube-tui-full-bin
pkgdesc = An aesthetically pleasing TUI frontend to browsing YouTube written in Rust. (Binary)
- pkgver = 0.6.0
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/Siriusmart/youtube-tui
arch = x86_64
license = GPL3
depends = libsixel
depends = libxcb
+ depends = openssl
optdepends = mpv: default video player
optdepends = konsole: default terminal emulator
optdepends = yt-dlp: default youtube downloader
provides = youtube-tui
conflicts = youtube-tui
- source = youtube-tui-0.6.0::https://github.com/Siriusmart/youtube-tui/releases/download/v0.6.0/youtube-tui-full_arch-x86_64
- sha512sums = 3b5bf0d7e45aa682c70346c3fedf29f285507ba4543cc634671316cd487ee43e151187d083df66ab08c5ee79378b617a1f9d39761ef938d4befdf29c4af7bca7
+ source = youtube-tui-0.8.0::https://github.com/Siriusmart/youtube-tui/releases/download/v0.8.0/youtube-tui-full_arch-x86_64
+ sha512sums = ffc00c17bebc0fbc7f32dfc102363c721ad1a3a415ac065468ba70ba181e72ab016a8381678cfb474e6a07b0d7ef8b62bdc57ec78af240aa014f05da9972fe30
pkgname = youtube-tui-full-bin
diff --git a/PKGBUILD b/PKGBUILD
index 10b2cfdb533e..7b4d09c4750e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,14 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: Zaedus <thezaedus@proton.me>
+# Maintainer: knedl1k <knedl1k At tuta Dot io>
+# Contributor: Zaedus <thezaedus@proton.me>
_pkgname="youtube-tui"
pkgname="${_pkgname}-full-bin"
-pkgver=0.6.0
+pkgver=0.8.0
pkgrel=1
pkgdesc="An aesthetically pleasing TUI frontend to browsing YouTube written in Rust. (Binary)"
arch=('x86_64')
url="https://github.com/Siriusmart/youtube-tui"
license=('GPL3')
-depends=('libsixel' 'libxcb')
+depends=('libsixel' 'libxcb' 'openssl')
optdepends=(
'mpv: default video player'
'konsole: default terminal emulator'
@@ -22,7 +18,7 @@ makedepends=()
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}-${pkgver}::https://github.com/Siriusmart/youtube-tui/releases/download/v${pkgver}/${_pkgname}-full_arch-x86_64")
-sha512sums=('3b5bf0d7e45aa682c70346c3fedf29f285507ba4543cc634671316cd487ee43e151187d083df66ab08c5ee79378b617a1f9d39761ef938d4befdf29c4af7bca7')
+sha512sums=('ffc00c17bebc0fbc7f32dfc102363c721ad1a3a415ac065468ba70ba181e72ab016a8381678cfb474e6a07b0d7ef8b62bdc57ec78af240aa014f05da9972fe30')
package() {
cd "${srcdir}"