summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Tyler-Moss2020-12-26 18:25:36 +0000
committerEden Tyler-Moss2020-12-26 18:25:36 +0000
commit2a169a2ec33b38919d0e401125a954825dd97164 (patch)
treeeea2c908d15dd2ef57ab0665a7a70224ddfbdb01
downloadaur-2a169a2ec33b38919d0e401125a954825dd97164.tar.gz
Initial pkg commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--youtube-tv-desktop-app.desktop9
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebfb45dfce7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = youtube-tv-desktop-app
+ pkgdesc = Youtube for TV Desktop app
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/etylermoss/youtube-tv-desktop
+ arch = x86_64
+ license = GPL3
+ makedepends = nodejs
+ makedepends = npm
+ depends = electron
+ provides = youtube-tv-desktop-app
+ source = https://github.com/etylermoss/youtube-tv-desktop/archive/v1.0.4.tar.gz
+ source = youtube-tv-desktop-app.desktop
+ sha256sums = a91911eafe473485ff3ee36e6aef08361e0cbea4391312a0b1cb24120a822bab
+ sha256sums = f3e6149e45a29e634990583a8f23c9ef6fd3d26aef903fd377b4c52c9fd88759
+
+pkgname = youtube-tv-desktop-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52e250e01272
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Eden Tyler-Moss <eden@etylermoss.com>
+
+pkgname=youtube-tv-desktop-app
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Youtube for TV Desktop app"
+arch=('x86_64')
+url="https://github.com/etylermoss/youtube-tv-desktop"
+license=('GPL3')
+depends=('electron')
+makedepends=('nodejs' 'npm')
+provides=('youtube-tv-desktop-app')
+source=(
+ "https://github.com/etylermoss/youtube-tv-desktop/archive/v$pkgver.tar.gz"
+ "youtube-tv-desktop-app.desktop"
+)
+sha256sums=(
+ a91911eafe473485ff3ee36e6aef08361e0cbea4391312a0b1cb24120a822bab
+ f3e6149e45a29e634990583a8f23c9ef6fd3d26aef903fd377b4c52c9fd88759
+)
+
+build() {
+ cd "$srcdir/youtube-tv-desktop-$pkgver"
+ npm install
+ npm run build-prod
+ sed -i '1s;^;#!/usr/bin/env electron\n;' build/index.js
+}
+
+package() {
+ install -Dm755 "$srcdir/youtube-tv-desktop-$pkgver/build/index.js" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/youtube-tv-desktop-$pkgver/youtube-512x512.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "youtube-tv-desktop-app.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+} \ No newline at end of file
diff --git a/youtube-tv-desktop-app.desktop b/youtube-tv-desktop-app.desktop
new file mode 100644
index 000000000000..77e429c3e2ef
--- /dev/null
+++ b/youtube-tv-desktop-app.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=YouTube TV Desktop
+Exec="/usr/bin/youtube-tv-desktop-app" %U
+Terminal=false
+Type=Application
+Icon=youtube-tv-desktop
+StartupWMClass=YouTube TV Desktop
+Comment=Electron wrapper for youtube.com/tv.
+Categories=Video; \ No newline at end of file